BASE DE CONNAISSANCES

Erreur "DataSourceException : Aucun utilisateur Tableau Server trouvé ... Impossible de se connecter au serveur" lors de l'actualisation du classeur basé sur un extrait


Date de publication : 10 Jul 2014
Date de dernière modification : 24 Aug 2022

Problème

Lorsque vous tentez d'actualiser un classeur contenant des sources de données publiées basées sur des extraits sur Tableau Server ou Tableau Cloud, l'erreur suivante peut se produire :
 
com.tableausoftware.nativeapi.dll.DataSourceException: Aucun utilisateur Tableau Server trouvé.
class DataSourceException
Impossible de se connecter au serveur « <nom serveur ou adresse IP> ». Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.

Environnement

  • Tableau Server
  • Tableau Cloud
  • Serveur de données

Résolution

Mettre à jour la connexion aux données Tableau Server :

  1. Vérifiez le nom ou l'adresse IP de votre Tableau Server.
  2. Dans Tableau Desktop, ouvrez le classeur.
  3. Faites un clic droit sur le nom de la source de données dans le volet Données et sélectionnez Serveur de données Tableau > Modifier le chemin d'accès au serveur et au site.
  4. Dans la boîte de dialogue Modifier la connexion de données Tableau Server, cliquez sur Modifier Connexion.
  5. Entrez le nom ou l'adresse IP de serveur approprié(e).
  6. Suivez les étapes restantes dans la fenêtre et cliquez sur OK.
  7. Republiez le classeur avec authentification par mot de passe intégré. Pour plus d'informations, consultez Intégration de mots de passe et authentification.
Si la solution ci-dessous ne permet pas de résoudre le problème, essayez la procédure décrite ci-dessous (nécessite Tableau Desktop): 

Étape 1 : Ajouter à nouveau la source de données

  1. Téléchargez le classeur depuis Tableau Server et ouvrez-le avec Tableau Desktop.
  2. Cliquez sur « Données » en haut de l'écran.
  3. Cliquez sur « Nouvelle source de données ».
  4. Cliquez sur « Tableau Server ».
  5. Sélectionnez alors la source d'origine de la source de données qui provoquait l'erreur.
  6. Cliquez sur le titre de votre feuille de calcul. Vous devriez maintenant voir deux sources de données portant le même nom. Un numéro sera ajouté à la nouvelle connexion, par exemple « sourcededonnées(2) ».

Étape 2 : Remplacer la connexion d'origine

  1. Faites un clic droit sur votre source de données d'origine figurant dans le volet Données (la première connexion, celle qui ne fonctionnait pas), et sélectionnez « Remplacer la source de données ».
  2. Assurez-vous que la source de données figurant dans le champ « Actuel » est la connexion originale défectueuse, et que la source de données dans le champ de remplacement est la connexion nouvelle que vous venez d'ajouter. 
  3. Cliquez sur « OK ».
  4. Enregistrez le classeur.
  5. Fermez le classeur puis rouvrez-le.
  6. Faites un clic droit sur la source de données dans le volet Données et survolez « Serveur de données Tableau » et « Modifier le chemin d'accès au serveur et au site ».
  7. Vérifiez alors que l'URL du serveur indiquée est correcte. Si tel est le cas, cliquez sur « Annuler ».
  8. Publiez ce classeur avec la nouvelle connexion à Tableau Server et essayez d'actualiser à nouveau.

Cause

Le nom ou l'adresse IP de Tableau Server a changé et les classeurs publiés sont configurés pour les anciennes informations de connexion, ou le classeur n'a pas d'informations d'identification intégrées.

Informations supplémentaires

Si vous rencontrez ce problème avec des classeurs contenant des sources de données intégrées, vérifiez que le compte Exécuter en tant qu'utilisateur pour Tableau Server dispose des autorisations correctes.Consultez Exécuter en tant qu'utilisateur dans Tableau pour en savoir plus sur la définition de toutes les autorisations Exécuter en tant qu'utilisateur appropriées.
Cet article vous a-t-il permis de résoudre le problème ?