ナレッジベース

エラー "The table "[Extract].[Extract]" does not exist. Unable to connect to the file "<filepath>"" (テーブル "[Extract].[Extract]" は存在しません。ファイル "<filepath>" に接続できません)


発行: 27 Sep 2013
最終修正日: 20 Jul 2023

問題

抽出に接続したワークブックを開くときに、次のエラーが発生する場合があります。

Tableau Data Engine Error: 4: SimpleDatabase::SelectMetadataName: expected found=1, actual found=0 (fk=1xxxxxx name="xxx" nameTable="xxx") (Tableau データ エンジン エラー: 4: SimpleDatabase::SelectMetadataName: 予想検出数=1, 実際の検出数=0 (fk=1xxxxxx name="xxx" nameTable="xxx"))
The table "[Extract].[Extract]" does not exist. (テーブル "[Extract].[Extract]" が存在しません。)

Unable to connect to the file "<filepath>". Check that the file exists and that you have sufficient access privileges for it. (ファイル "<filepath>" に接続できません。ファイルが存在し、ファイルに対する十分なアクセス権限があることを確認してください。)

環境

  • Tableau Desktop 
  • Tableau Server
  • 抽出

解決策

Tableau Server の場合:
Tableau Desktop で抽出の問題を修正し、ワークブックをサーバーにパブリッシュし直します。

Tableau Desktop の場合:
  1. エラー メッセージのダイアログ ボックスで [OK] をクリックします。
  2. 接続を編集するようにメッセージが表示されたら、[はい] をクリックします。
  3. [抽出の再生成] を選択してから [OK] をクリックします。
詳細については、「抽出を使用」を参照してください。

原因

抽出が破損しています。

詳細情報


この記事で問題は解決しましたか?