기술 자료

Tableau Server 또는 기기 레이아웃을 사용하는 Tableau Cloud에 게시한 후 대시보드가 비어 있거나 내용이 없음


게시 날짜: 30 Jul 2013
마지막 수정 날짜: 19 Jun 2023

문제

기기 레이아웃이 포함된 Tableau Server 또는 Tableau Cloud에 통합 문서를 게시한 후 대시보드 또는 뷰가 빈 상태로 표시되거나 Tableau Desktop에서 볼 때 표시된 뷰와 다르게 표시됩니다.

환경

  • Tableau Server
  • Tableau Cloud

해결 방법

  1. Tableau Desktop에서 통합 문서를 엽니다.
  2. 기본 레이아웃에 더해 대체 레이아웃(태블릿, 전화 또는 데스크톱)이 있는지 확인합니다.
  3. 모든 레이아웃을 하나씩 클릭하여 기본 레이아웃과 구분되는 레이아웃이 있는지 찾습니다.
  4. 기본 뷰와 다른 레이아웃(태블릿, 전화 또는 데스크톱)을 제거하거나 업데이트하여 기본 뷰와 일치시킵니다.
  5. 영향을 받는 통합 문서를 대체할 통합 문서를 다시 게시하여 업데이트하고 문제를 수정합니다.
예제를 확장하려면 클릭

원인

대체 레이아웃이 실수로 추가되거나 Tableau Desktop의 "기본" 레이아웃과 다를 수 있습니다. 이 경우 해당 레이아웃과 관련된 장치에서 게시된 통합 문서를 보면 Tableau Server 또는 Tableau Cloud에서 통합 문서를 볼 때 Tableau Desktop에서 표시되는 것과 다르게 나타납니다. 이 문제는 실제 콘텐츠가 콘텐츠의 기본 뷰 레이아웃과 비교할 때 해당 레이아웃에서 다른 경우에만 발생합니다(예: 일부 뷰가 비어 있거나 누락됨).
 

추가 정보

참고: 이 문서는 대체 레이아웃으로 인해 대시보드가 공백으로 나타나는 문제만을 다룹니다. 대시보드/뷰가 공백으로 나타나는 원인은 다양합니다.  
새로운 버전의 Tableau Desktop에서 예전 버전의 Tableau Server로 통합 문서를 게시했을 경우에도 뷰가 공백으로 나타날 수 있습니다. 새로운 버전의 Tableau Desktop에서 사용된 기능이 예전 버전의 Tableau Server에 존재하지 않는다면 뷰가 표시되지 않습니다.
옵션 1: 통합 문서를 호환되는 버전의 Tableau Desktop으로 내보낸 다음 호환되는 버전의 Tableau Desktop에서 게시하기
옵션 2: Tableau Desktop와 호환되는 새로운 버전의 Tableau Server로 업그레이드하기

혹은 다음과 같은 경우가 해당될 수도 있습니다.

사용자 이름 함수를 사용할 때 필터가 있는 뷰를 게시한 후 뷰가 비어 있음
게시한 후 웹 기반 URL에 연결된 웹 페이지 개체가 비어 있음
게시한 후 로컬 파일에 연결된 웹 페이지 개체가 비어 있음
퀵 필터 사용 시 대시보드 시트가 공백으로 표시됨
 
이 문서로 문제가 해결되었습니까?