知識庫

錯誤「No license found for 'TableauServer」


發佈時間 : 26 Feb 2013
上次修改日期 : 20 Jul 2023

問題

當您嘗試啟動 Tableau Server 許可證金鑰時,可能會發生以下錯誤:

未找到「TableauServer」的許可證

此外,「管理產品金鑰」頁上不會出現金鑰。

環境

  • Tableau Server 2018.1.x 及更早版本
  • Tabadmin(TSM 先前版本)

解決方法

選項 1

在本地防火牆中為以下過程設定例外:
  • tableau.exe
  • lmgrd.exe

選項 2

  1. 禁用電腦上的本地防火牆。
  2. 停用防毒軟體。如果無法停用,請將 Tableau 資料夾從防毒軟體中排除。
  3. 打開 C:\Windows\System32\drivers\etc\hosts,並刪除或注釋掉包含以下內容的任何行:127.0.0.1localhost 或電腦的主機名。
  4. 重新啟動 FlexNet 授權和 Tableau Server 授權管理員 (tablicsrv) 服務。有關詳細資訊,請參閱 Microsoft TechNet 上的重新啟動服務
  5. 確認辅助登入服務已啟動,並且將繼續在啟動時自動啟動:
    1. 執行驗證 Tableau 服務設定中的步驟。
    2. 右鍵按一下服務名稱,然後選擇「啟動」
    3. 右鍵按一下服務名稱,然後選擇「屬性」。將「啟動類型」設定為「自動」
  6. 重新嘗試連接到 Tableau Server。
  7. 重新啟用本地防火牆。

     

      原因

      本地 tablicsrv 服務無法連接到 Tableau Server FlexNet Licensing Service。

      其他資訊

      如果上面的解決方案没有解決此問題,則可以嘗試以下疑難解答選項:

      • 檢查防火牆是否阻止與許可伺服器的網路通信。McAfee 之類的防毒軟體通常會啟用自身的防火牆。
      • 檢查連接埠 27000 是否可用。
      • 檢查系統日期和時間是否正確。
      • 確保以管理員身份運行「管理產品金鑰」
      • 如果連接到 VPN,請在啟動許可證金鑰之前禁用 VPN。可在啟動許可證之後啟用 VPN。
      • 這兩項服務都應該設定為以系統帳戶運行。
      • 雖然在啟動過程中會出現錯誤消息,但會在受信任存儲中創建記錄。重新啟動服務後,金鑰將自動出現在「管理產品金鑰」頁上。

      如果上述解決方案或疑難解答步驟均無法解決問題,請聯繫 Tableau 技術支援並提供以下資訊:

      您可能會在日誌檔案中看到的相關錯誤消息包括:

       
      消息日誌檔案含義
      lc_checkout return value: -95 (internal code)tabsrvlic.log or wgserver_lic.logtablicsrv cannot connect to FLEXnet.
      Vendor daemon can't talk to lmgrd (License server machine is down or not responding. (-96,491)tablicsrv.logtablicsrv cannot connect to FLEXnet.
      -97 (internal code)tabsrvlic.logtablicsrv cannot be started (check Log On As settings in Services)


      這篇文章是否解決了問題?