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Fehler "No license found for 'TableauServer'"


Veröffentlicht: 26 Feb 2013
Zuletzt geändert am: 20 Jul 2023

Problem

Wenn Sie versuchen, einen Tableau Server-Lizenzschlüssel zu aktivieren, tritt ggf. der folgende Fehler auf:

Keine Lizenz für 'TableauServer' gefunden

Außerdem werden auf der Seite "Produktschlüssel verwalten" keine Schlüssel angezeigt.

Umgebung

  • Tableau Server 2018.1.x und früher
  • Tabadmin (vor TSM)

Lösung

Option 1

Legen Sie Ausnahmen in der lokalen Firewall für die folgenden Prozesse fest:
  • tableau.exe
  • lmgrd.exe

Option 2

  1. Deaktivieren Sie die lokale Firewall auf dem Computer.
  2. Deaktivieren Sie die Antivirenprüfung. Wenn die Deaktivierung nicht möglich ist, schließen Sie den Tableau-Ordner aus der Antivirenprüfung aus.
  3. Öffnen Sie C:\Windows\System32\drivers\etc\hosts, und löschen Sie alle Zeilen, die Folgendes enthalten (oder kommentieren Sie diese Zeilen aus): 127.0.0.1localhost oder Hostname des Computers.
  4. Starten Sie den FlexNet-Lizenzierungsdienst und den Tableau Server-Lizenzmanager-Dienst (tablicsrv) neu. Weitere Informationen finden Sie unter Neustarten eines Dienstes auf Microsoft TechNet.
  5. Prüfen Sie, ob der Dienst für die sekundäre Anmeldung gestartet wurde und weiterhin automatisch nach dem Starten gestartet wird:
    1. Befolgen Sie die Anweisungen unter Überprüfen der Tableau-Diensteinstellungen.
    2. Klicken Sie mit der rechten Maustaste auf den Dienstnamen, und wählen Sie Starten aus.
    3. Klicken Sie mit der rechten Maustaste auf den Dienstnamen, und wählen Sie "Eigenschaften" aus.Wählen Sie unter Starttyp die Option Automatisch.
  6. Versuchen Sie erneut, eine Verbindung zu Tableau Server herzustellen.
  7. Aktivieren Sie die lokale Firewall wieder.

     

      Ursache

      Der lokale tablicsrv-Dienst kann keine Verbindung zum Tableau Server-FlexNet-Lizenzierungsdienst herstellen.

      Zusätzliche Informationen

      Falls das Problem mit den oben stehenden Lösungen nicht behoben wurde, probieren Sie die folgenden Lösungsoptionen aus:

      • Überprüfen Sie, ob eine Firewall den Netzwerkverkehr zum Lizenzserver blockiert. Antivirensoftware wie McAfee aktiviert in der Regel eine eigene Firewall.
      • Überprüfen Sie, ob Port 27000 verfügbar ist.
      • Prüfen Sie, ob das Systemdatum und die Systemuhrzeit korrekt sind.
      • Führen Sie die Funktion Produktschlüssel verwalten als Administrator aus.
      • Wenn Sie eine Verbindung zu einem VPN herstellen, deaktivieren Sie zunächst das VPN, und aktivieren Sie dann erst den Lizenzschlüssel. Nach dem Aktivieren der Lizenz können Sie das VPN wieder aktivieren.
      • Für beide Dienste muss die Ausführung als Systemkonto festgelegt sein.
      • Obwohl die Fehlermeldung während der Aktivierung angezeigt wird, wird ein Datensatz im verbürgten Speicher angelegt. Nach dem Neustarten der Dienste wird automatisch ein Schlüssel auf der Seite "Produktschlüssel verwalten" angezeigt.

      Wenn das Problem durch keine der oben stehenden Lösungen oder Schritte zur Fehlerbehebung behoben werden kann, wenden Sie sich an den technischen Support von Tableau, und geben Sie die folgenden Informationen an:

      Zugehörige Fehlermeldungen, die ggf. in den Protokolldateien aufgeführt werden:

       
      MeldungProtokolldateiBedeutung
      lc_checkout return value: -95 (internal code)tabsrvlic.log or wgserver_lic.logtablicsrv cannot connect to FLEXnet.
      Vendor daemon can't talk to lmgrd (License server machine is down or not responding. (-96,491)tablicsrv.logtablicsrv cannot connect to FLEXnet.
      -97 (internal code)tabsrvlic.logtablicsrv cannot be started (check Log On As settings in Services)


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