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Erreur "No Tableau Server user found" lors de la connexion à la source de données ou de l'affichage du tableau de bord


Date de publication : 28 Jan 2013
Date de dernière modification : 24 Aug 2022

Problème

Lorsque vous tentez d'accéder à des tableaux de bord ou d'envoyer des e-mails d'abonnement à Tableau Server ou Tableau Cloud, l'erreur suivante peut se produire :

No server user found class DataSourceException Unable to connect to server <server name or IP address>. Check that the server is running and that access privileges to the requested database. (Aucun utilisateur de serveur n'a été trouvé classe DataSourceException impossible de se connecter au serveur <server name or IP address>. Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)

Lorsque vous tentez de vous connecter à un source de données publiée depuis Tableau Desktop, l'erreur suivante peut se produire :
 
com.tableausoftware.controller.dataserver.SessionController - Error response. code:401 type:DataServerNoAuth msg:No Tableau Server user found. (Aucun utilisateur Tableau Server n'a été trouvé)

Environnement

  • Tableau Server
  • Tableau Cloud
  • Tableau Desktop avec des sources de données publiées
  • Serveur de données

Résolution

Deux causes courantes ont été identifiées pour ce problème. Suivez les étapes ci-dessous en fonction de votre situation.

Cause 1 : Autorisations utilisateur (Tableau Server et Tableau Cloud)

Si certains utilisateurs ou certains classeurs sont concernés, assurez-vous que :
Les utilisateurs concernés disposent de l'autorisation CONNEXION pour la source de données publiée. Voir Fonctionnalités que vous pouvez définir sur des sources de données.
OU
Le publicateur a intégré les informations d'identification pour les classeurs concernés.

 

Cause 2 : Proxy de transfert (Tableau Server uniquement)

Si tous les utilisateurs et tous les classeurs ou sources de données sont affectés et qu'un serveur proxy de transfert est utilisé, configurez le proxy de manière à ce que des exceptions soient spécifiées dans Configurer un serveur proxy de transfert. Notez que cette configuration doit être effectuée sur la machine principale et toutes les machines workers dans un environnement distribué.
 

Cause

Cause 1 : L'utilisateur n'est pas autorisé à accéder à la source de données publiée.

Cause 2 : Un proxy de transfert interfère avec les communications du serveur de données. Toutes les communications du serveur de données se font sur HTTP.

Informations supplémentaires

Si des classeurs contenant des sources de données intégrées rencontrent le problème, vérifiez que le compte Exécuter en tant qu'utilisateur pour Tableau Server dispose des autorisations correctes. Pour plus d'informations sur la configuration de toutes les autorisations Exécuter en tant qu'utilisateur appropriées, consultez l'article suivant de l'aide de Tableau : Exécuter en tant qu'utilisateur.
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