Errore "Maintenance expired on <date>. Maintenance is required through <date> to run this version." durante l'installazione o attivazione
Pubblicato: 28 Jun 2017 Data dell'ultima modifica: 20 Jul 2023
Problema
Quando provi ad attivare o installare Tableau Desktop, si verifica il seguente errore:
La manutenzione è scaduta il <data>. La manutenzione è richiesta attraverso <data> per eseguire questa versione.
Ambiente
Tableau Desktop
Tableau Server
Windows
Mac OS
Soluzione
Controlla il Portale clienti di Tableau o chiedi all'amministratore del portale di visualizzare la chiave specifica e la data di fine della manutenzione in corso.
Se Tableau Desktop è stato attivato mediante il normale processo di attivazione e la manutenzione corrente è mostrata nel Portale clienti ma non in Gestisci codici prodotto, procedi all'aggiornamento del codice. Per ulteriori informazioni, vedi Aggiornare la data di manutenzione del codice prodotto.
Se Tableau Desktop è stato attivato offline e la manutenzione corrente viene mostrata nel Portale clienti ma non in Gestisci codici prodotto, procedi all'attivazione offline utilizzando il codice che presenta la manutenzione corrente. Per ulteriori informazioni, consulta Attivazione offline di Tableau.
Se il codice non presenta la manutenzione corrente, potrai solo installare e attivare le versioni di Tableau Desktop rilasciate prima della data di fine della manutenzione. Vedi Download dei prodotti e note sulla versione per la data di rilascio di ciascuna versione.
Se il codice presenta la manutenzione corrente ma continui a ricevere l'errore, installa una versione di Tableau Desktop rilasciata prima della data di fine della manutenzione indicata nel messaggio di errore. Aggiorna la chiave in quella versione. Se la soluzione funziona, dovrebbe essere possibile aprire e utilizzare, senza errori, le versioni più recenti di Tableau Desktop.
Se è richiesta ulteriore manutenzione, contatta il gestore dell'account di Tableau.
Causa
I seguenti scenari possono causare questo errore:
La chiave non è stata aggiornata.
La chiave è stata attivata offline ed è ora disponibile una chiave più recente con manutenzione aggiornata.
La manutenzione della chiave è scaduta.
Ulteriori informazioni
Di seguito è presentato un esempio dei passaggi necessari nel caso in cui la manutenzione sia stata verificata come corrente ma si riceve l'errore "Maintenance expired":
1. Tieni a mente la data di fine della manutenzione indicata nel messaggio di errore. In questo caso è "23-09-2016". Dobbiamo trovare una versione di Tableau Desktop che è stata distribuita prima di questa data nel 2016. 2. Passa alla pagina Download prodotto (https://www.tableau.com/it-it/support/releases. È necessario approfondire le singole versioni principali (la seconda cifra del numero di versione) per individuare una versione di Tableau Desktop rilasciata prima del 23 settembre 2016. In questo caso la versione è Tableau Desktop 10.0.1, rilasciata il 19 settembre 2016. 3. Scarica e installa Tableau Desktop 10.0.1. Passa a Gestisci codici prodotto e seleziona il codice desiderato. Seleziona aggiornamento. La chiave dovrebbe essere aggiornata per mostrare la manutenzione corrente. 4. Ora che il codice di Tableau Desktop è stato aggiornato a una versione di Tableau Desktop uscita prima della scadenza del codice originale, dovrebbe essere possibile aprire e utilizzare le versioni successive di Tableau Desktop. Potrebbe essere necessario riavviare queste versioni e/o registrarsi, ma non dovrebbe essere richiesta una chiave. Potrebbe essere necessario aggiornare la chiave in Gestisci i codici prodotto.
Grazie per aver inviato il tuo feedback sull'efficacia dell'articolo.