BASE DE CONNAISSANCES

Erreur "Maintenance expired <date>. Maintenance is required through <date> to run this version." lors de l'installation ou de l'activation


Date de publication : 28 Jun 2017
Date de dernière modification : 20 Jul 2023

Problème

Lorsque vous tentez d'activer ou d'installer Tableau Desktop, l'erreur suivante se produit :

Maintenance expired on <date>. Maintenance is required through <date> to run this version. (La maintenance a expiré le <date>. La maintenance est requise jusqu'à <date> pour exécuter cette version.)

Environnement

  • Tableau Desktop
  • Tableau Server
  • Windows
  • Mac OS

Résolution

Consultez votre Portail client Tableau ou demandez à votre administrateur de portail Tableau d'afficher la clé spécifique et la date de fin du contrat de maintenance actuel. 
  • Si Tableau Desktop a été activé selon le processus d'activation standard et qu'un contrat de maintenance s'affiche dans le Portail client, mais n'est pas reflété dans Gérer les clés produit, actualisez la clé. Pour plus d'informations, consultez Actualiser la date de maintenance pour la clé produit.
  • Si Tableau Desktop a été activé hors ligne et qu'un contrat de maintenance actuel est affiché dans le Portail client, mais n'est pas reflété dans Gérer les clés produit, activez-le hors ligne à l'aide de la clé associée à la maintenance actuelle indiquée.Consultez Activer Tableau hors ligne pour plus d'informations. 
  • Si la clé ne dispose pas d'un contrat de maintenance actuel, vous ne pourrez installer et activer que les versions de Tableau Desktop qui ont été distribuées avant la date de fin de maintenance. Consultez Téléchargements de produits et notes de version pour connaître la date de distribution de chaque version. 
  • Si un contrat de maintenance est en cours pour le clé, mais que l'erreur persiste, installez une version de Tableau Desktop qui a été distribuée avant la date de fin de maintenance indiquée dans le message d'erreur. Actualisez la clé dans cette version. Une fois cette opération terminée, vous devriez pouvoir ouvrir et utiliser, sans erreur, des versions plus récentes de Tableau Desktop.

Si une maintenance supplémentaire est nécessaire, contactez votre Account Manager Tableau. 
 

Cause

Les scénarios suivants peuvent générer cette erreur :
  • La clé n'a pas été actualisée.
  • La clé a été activée hors ligne et une clé plus récente avec mise à jour de la maintenance est maintenant disponible.
  • Le contrat de maintenance de la clé a expiré.

Informations supplémentaires

Voici un exemple des étapes nécessaires lorsque le contrat de maintenance a été vérifié comme étant en cours, mais que l'erreur « Maintenance expirée » s'affiche :

1. Notez la date de fin de maintenance dans le message d'erreur. Dans ce cas, il s'agit du « 2016-09-23 ». Nous devons trouver et installer une version de Tableau Desktop qui a été distribuée avant cette date en 2016.
2. Accédez à notre page de téléchargements de produits (https://www.tableau.com/support/releases. Vous devez descendre dans la hiérarchie des distributions majeures individuelles (le(s) second(s) chiffre(s) dans le numéro de version) pour localiser une version de Tableau Desktop distribuée avant le 23 septembre 2016. Dans ce cas, la version est Tableau Desktop 10.0.1, qui a été distribuée le 19 septembre 2016.
3. Téléchargez et installez Tableau Desktop 10.0.1. Accédez à Gérer les clés produit et sélectionnez la clé souhaitée. Sélectionnez Actualiser. La clé devrait se mettre à jour de manière à afficher la maintenance actuelle.
4. Maintenant que la clé de Tableau Desktop a été actualisée dans une version de Tableau Desktop qui a été distribuée avant l'expiration de la clé d'origine, il devrait être possible d'ouvrir et d'utiliser des versions ultérieures de Tableau Desktop. Vous devrez peut-être redémarrer ces versions et/ou les enregistrer. Par contre, une clé ne devrait pas vous être demandée. Vous devrez peut-être actualiser la clé dans Gérer les clés produit.
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