기술 자료

백업 만들기가 실패할 때 "The system cannot find the file specified" 오류 발생


게시 날짜: 15 Feb 2017
마지막 수정 날짜: 24 Aug 2022

문제

모니터링 응용 프로그램 또는 바이러스 백신에 액세스 시점 검사 기능이 있는 경우 tabadmin 백업이 실패하고 다음 오류가 발생합니다. 
Error:
cannot delete the file
(Full file path/.tsbak.tmp)(오류: 파일을 삭제할 수 없음(전체 파일 경로/.tsbak.tmp))
The system cannot find the file specified.(시스템이 지정된 파일을 찾을 수 없습니다.) 
System ERROR:(시스템 오류:) 
The system cannot find the file specified.(시스템이 지정된 파일을 찾을 수 없습니다.)

 
또한 7zip을 사용하는 경우 tabadmin backup 명령을 실행할 때 다음 오류가 발생할 수 있습니다.
*** Backup failed!(백업 실패!) 
*** Error: Command '"<Tableau Server path /7z.exe>" a -tzip -mx1 -mcu=on -bb1 "<Back up full path /tsbak.tmp####>" * "<Tableau Server path /webdataconnectors"' failed with code 2, result was(오류: '"<Tableau Server 경로 /7z.exe>" a -tzip -mx1 -mcu=on -bb1 "<백업 전체 경로 /tsbak.tmp####>" * "<Tableau Server 경로 /webdataconnectors"' 명령이 코드 2로 실패함, 결과) 
7-Zip [64] 15.14 : Copyright (c) 1999-2015 Igor Pavlov : 2015-12-31 
failed with code 2, result was(코드 2로 실패함, 결과) 
7-Zip [64] 15.14 : Copyright (c) 1999-2015 Igor Pavlov : 2015-12-31 
Open archive: (Full file path/.tsbak.tmp)(아카이브 열기: (전체 파일 경로/.tsbak.tmp))

환경

Tableau Server

해결 방법

액세스 시 검사 기능을 실행하는 소프트웨어의 제외 목록에 Tableau Server 폴더를 추가합니다.

원인

바이러스 백신 또는 모니터링 소프트웨어가 활성 검사를 실행 중이며 파일을 너무 오래 점유하고 있습니다. 콘텐츠가 검사될 때 Tableau Server가 파일 검색을 시도하고 실패한 후 오류 메시지를 표시합니다.
이 문서로 문제가 해결되었습니까?