KNOWLEDGE BASE

Fehler: "The system cannot find the file specified", wenn die Backup-Erstellung fehlschlägt


Veröffentlicht: 15 Feb 2017
Zuletzt geändert am: 24 Aug 2022

Problem

Wenn eine Überwachungsanwendung oder ein Virenschutzsystem Scans beim Zugriff durchführt, schlägt "tabadmin backup" fehl, und zwar mit folgendem Fehler: 
Error: 
cannot delete the file (Fehler: Datei kann nicht gelöscht werden)
(Full file path/.tsbak.tmp)
The system cannot find the file specified. (Das System kann die angegebene Datei nicht finden.)
System ERROR: 
The system cannot find the file specified. (System-Fehler: Das System kann die angegebene Datei nicht finden.)

 
Zusätzlich tritt möglicherweise folgender Fehler auf, wenn Sie 7.zip nutzen und den Befehl "tabadmin backup" ausführen:
*** Backup failed! (Backup fehlgeschlagen)
*** Error: Command '"<Tableau Server path /7z.exe>" a -tzip -mx1 -mcu=on -bb1 "<Back up full path /tsbak.tmp####>" * "<Tableau Server path /webdataconnectors"' failed with code 2, result was (Befehl '"<Tableau Server-Pfad/7z.exe>" a -tzip -mx1 -mcu=on -bb1 "<vollständiger Backup-Pfad/tsbak.tmp####>" * "<Tableau Server-Pfad/webdataconnectors"' fehlgeschlagen mit Code 2, Ergebnis war
7-Zip [64] 15.14 : Copyright (c) 1999-2015 Igor Pavlov : 2015-12-31 
failed with code 2, result was (fehlgeschlagen mit Code 2, Ergebnis war)
7-Zip [64] 15.14 : Copyright (c) 1999-2015 Igor Pavlov : 2015-12-31 
Open archive: (Full file path/.tsbak.tmp) (Archiv öffnen: (Vollständiger Dateipfad/.tsbak.tmp)

Umgebung

Tableau Server

Lösung

Fügen Sie Tableau Server-Ordner zur Ausschlussliste der Software hinzu, die beim Zugriff auf Scans ausgeführt wird.

Ursache

Eine Virenschutz- oder Überwachungssoftware führt aktiv Scans durch und hält sich mit der Datei zu lange auf. Da die Inhalte gescannt werden, versucht Tableau Server, die Datei abzurufen, ohne Erfolg, und damit wird die Fehlermeldung ausgegeben.
Hat dieser Artikel das Problem gelöst?