ナレッジベース

スケジュールされた抽出更新が断続的に失敗し、エラー メッセージが表示されない


発行: 21 Oct 2016
最終修正日: 20 Jul 2023

問題

パブリッシュされた抽出が 1 日を通して頻繁に更新されるようにスケジュールされている場合、一部の抽出は期待どおりに頻繁に更新されません。
さらに、「[datasource name extract refresh] is already queued. Not queuing a duplicate ([データソース名の抽出更新] は既にキューに入れられています。重複はキューに入れていません。)」というメッセージがバックグラウンド ログに何度も表示されます。

環境

Tableau Server 

解決策

次のオプションのいずれかで問題が解決する場合があります。
オプション 1
データを可能な限り最新に保つことが重要な場合は、データベースへのライブ接続を作成して、抽出が定期的に更新されないようにすることを検討してください。
オプション 2
Tableau Server の抽出レポートのバックグラウンド タスクを使用して、更新ウィンドウよりも処理に時間がかかる抽出を特定します。抽出の完了に 20 分かかる場合、抽出を 15 分ごとに更新すると、その単一の抽出の更新によってバックグラウンダーが独占されます。
オプション 3
抽出更新の頻度を減らします。抽出がすべて 15 分間隔で更新される場合は、30 分のスケジュールに増やします。
オプション 4
Tableau Server プロセスを再構成してバックグラウンドの数を増やします。

注: 使用可能なシステム リソースがない場合、バックグラウンド プロセス数を増やしても問題は解決しません。


 

原因

バックグラウンダーが過負荷になり、使用可能な時間内にジョブを完了できません。

詳細情報

  • バックグラウンダー ログ フォルダーで「Storing to repository (リポジトリへの保存)」というフレーズを検索して、抽出更新が成功したインスタンスを見つけます。
  • バックグラウンダー ログ フォルダーで「already queued. Not queuing a duplicate (すでにキューに入れられています。重複はキューに入れていません。)」というフレーズを検索して、すでに実行中にトリガーされている抽出更新のインスタンスを見つけます。
  • 抽出のバックグラウンド タスク レポートに表示されるエラー メッセージはありません。

この記事で問題は解決しましたか?