KNOWLEDGE BASE

Fehler: "Data Extract Required" (Datenextrakt erforderlich) beim Speichern der Arbeitsmappe unter Tableau Public


Veröffentlicht: 23 Feb 2016
Zuletzt geändert am: 27 Jul 2023

Problem

Beim Arbeiten in der Tableau Public Desktop-Clientsoftware kann nach dem Anmelden beim Tableau Public Server der folgende Fehler auftreten:
 
Data Extract Required (Datenextrakt erforderlich)
The Tableau server you are publishing to does not permit external database connections. Use the Data menu to create an extract for the following data source: (Auf dem Tableau Server, auf dem Sie veröffentlichen möchten, sind keine externen Datenbankverbindungen gestattet. Verwenden Sie das Datenmenü, um einen Extrakt der folgenden Datenquelle zu erstellen:)
<data-source-name>

Vom Benutzer hinzugefügtes Bild

Umgebung

  • Tableau Public Server
  • Tableau Desktop
  • Direktdatenverbindung 

Lösung

Der Screenshot des Fehlers zeigt, dass es möglich ist, einen Extrakt über das Datenmenü zu erstellen, aber dieser nicht im Tableau Public Desktop verfügbar ist. Der Fehler-Screenshot enthält ungültige Informationen für die Public Desktop-Version. Es ist nicht möglich, eine Extrakterstellung im Tableau Public Desktop zu erzwingen. Dieser Fehler kann auftreten, wenn Sie mit einer Live-Datenquelle in Tableau Public arbeiten, nachdem Sie sich bei Tableau Public Server angemeldet haben.  Führen Sie Folgendes aus, um das Problem zu lösen:

1. Schließen Sie das Fehlerfenster und schließen Sie Updates für die Arbeitsmappe ab.  
2. Veröffentlichen Sie die Arbeitsmappe an den Tableau Public Server, wo die Veröffentlichen-Funktion den Extrakt erstellt. Wählen Sie Datei > In Tableau Public speichern oder In Tableau Public speichern als aus.

 Für eine Arbeitsmappe, die eine Direktverbindung zu einer unterstützten Datenquelle nutzt, wenn die Arbeitsmappe auf dem Tableau Public Server veröffentlicht wird, erstellt Tableau Public Desktop den Extrakt standardmäßig.

Vom Benutzer hinzugefügtes Bild

Nach der Veröffentlichung der Arbeitsmappe auf dem Tableau Public Server werden die Daten in der Arbeitsmappe als Extrakt angezeigt.

Vom Benutzer hinzugefügtes Bild

Hinweis: Wenn Sie eine Arbeitsmappe aus einer anderen Quelle erhalten, in Tableau Public Desktop geöffnet und dann beim Versuch der Veröffentlichung eine Fehlermeldung erhalten haben, müssen Sie sich an den Besitzer der Arbeitsmappe wenden, damit dieser die Daten extrahiert.  Es ist nicht möglich, in Tableau Public Desktop einen Extrakt über die Hauptsymbolleiste oder das Fenster "Datenbereich" zu erstellen.
 

 

Ursache

Tableau Desktop Public Edition und Tableau Public (Internet) arbeiten mit Daten aus Microsoft Excel, mehreren Textdateiformaten, statistischen Daten, Google Sheets und Webdaten-Connectoren.  Es ist nicht möglich, mit Tableau Public Desktop eine Arbeitsmappe lokal zu speichern oder einen Extrakt manuell zu erstellen.

Der Fehler kann auftreten, wenn Sie sich nur bei Tableau Public Server anmelden, während die Datenquelle live ist, da der Tableau Public Desktop erkennt, dass die Daten nicht extrahiert sind.  

Zusätzliche Informationen

Die Tableau Desktop Public Edition zeigt diese Fehlermeldung normalerweise nicht an, da Tableau Desktop Public einen Extrakt der Datenquelle automatisch beim Veröffentlichen der Arbeitsmappe auf dem Tableau Public Server (Internet) speichert.  

Weitere Informationen zu Tableau Public und dazu, wie Google Sheets-Daten aktualisiert werden, finden Sie unter Häufig gestellte Fragen zu Tableau Public.

Tableau Community-Diskussion zu einem Fehler beim Verbinden mit dem Tableau Public Server.

Ist Tableau Public verfügbar oder gibt es einen umfassenderen Betriebsfehler?  Prüfen Sie die Tableau Trust-Site.
Hat dieser Artikel das Problem gelöst?