知識庫

錯誤:「使用者 <username> 無法刪除,因為該使用者擁有內容。」 當嘗試刪除使用者時


發佈時間 : 11 Feb 2016
上次修改日期 : 06 Mar 2024

問題

嘗試刪除使用者時,即使使用者看起來沒有任何工作簿、檢視、資料來源等,也可能會出現以下錯誤訊息:
無法刪除 <username>,因為該使用者擁有內容。已取消 <username> 的授權。

環境

  • Tableau Server 
  • Tableau Cloud

解決方法

步驟 1 - 尋找使用者擁有的內容
  1. 導覽到擁有者的使用者頁面 (搜尋擁有者的名稱,並在「使用者」下選取其名稱)。
  2. 使用者擁有的所有內容 (包括專案) 將出現在獨立的索引標籤中。 
  3. 傳輸內容給其他使用者。
注意
確定在網站設定頁面上啟用建立「資料問答」濾鏡與集合,因為當其停用時,對應的索引標籤會隱藏,且網站管理員無法在 UI 中檢查這些內容。

步驟 2 - 尋找訂閱

Tableau Server 管理員可以導覽至工作 > 訂閱,且可能有仍然與使用者關聯的訂閱。  可能無法透過使用者搜尋找到與使用者關聯的訂閱。

按「訂閱」欄進行排序,然後捲動到使用者。  使用者可能有仍與其帳戶關聯的「訂閱者」。 請記下有訂閱的使用者,然後在新的內容擁有者下重新訂閱。

如果使用者訂閱了檢視,然後遭取消授權,則其訂閱仍然存在,但不會傳送電子郵件。  針對非常大的使用者群,如果未經授權的使用者是唯一得到訂閱的使用者,則刪除該使用者的訂閱對於伺服器效能非常重要。  Tableau Server 將完成這項工作,但不會傳送電子郵件。 
 

原因

如果使用者擁有任何內容,包括專案,則無法移除使用者,但使用者將遭取消授權。有關詳情,請參閱 Tableau Cloud 說明以從伺服器中移除使用者

對於訂閱,若使用者 A 的訂閱者為使用者 B,則該訂閱在使用者 A 的內容頁面中不可見。  使用者 A 沒有權限可看見特定使用者訂閱的項目。
這篇文章是否解決了問題?