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Fehler "Benutzer <Benutzername> konnte nicht gelöscht werden, da dieser Benutzer eigene Inhalte besitzt." beim Versuch, einen Benutzer zu löschen


Veröffentlicht: 11 Feb 2016
Zuletzt geändert am: 06 Mar 2024

Problem

Beim Versuch, einen Benutzer zu löschen, wird ggf. die folgende Fehlermeldung angezeigt, auch wenn der Benutzer anscheinend nicht der Besitzer der Arbeitsmappen, Ansichten, Datenquellen usw. ist:
Benutzer <Benutzername> konnte nicht gelöscht werden, weil dieser Benutzer ein Besitzer von Inhalten ist. Die Lizenz für <Benutzername> wurde aufgehoben.

Umgebung

  • Tableau Server 
  • Tableau Cloud

Lösung

Schritt 1: Suchen Sie die Inhalte, die der Benutzer besitzt
  1. Navigieren Sie zur Benutzerseite des Eigentümers (suchen Sie nach dem Namen des Eigentümers, und wählen Sie unter "Benutzer" den Namen aus).
  2. Alle Inhalte, deren Eigentümer der Benutzer ist, einschließlich Projekte, werden in separaten Registerkarten angezeigt. 
  3. Übertragen Sie die Inhalte auf einen anderen Benutzer.
Anmerkung:
Stellen Sie sicher, dass Sie die Erstellung von "Frag die Daten"-Linsen und -Sammlungen auf der Seite Site-Einstellung aktivieren, denn wenn diese deaktiviert sind, werden die entsprechenden Registerkarten ausgeblendet und der Site-Administrator kann diese Inhalte nicht in der Benutzeroberfläche überprüfen.

Schritt 2: Suchen Sie Abonnements

Ein Tableau Server-Administrator kann zu Aufgaben > Abonnements navigieren. Möglicherweise ist dort noch ein Abonnement mit dem Benutzer verknüpft.  Bei einer Benutzersuche wird das mit dem Benutzer verknüpfte Abonnement möglicherweise nicht gefunden.

Sortieren Sie die Ergebnisse nach der Spalte "Abonnements" und führen Sie dann einen Bildlauf zum Benutzer aus.  Möglicherweise ist die Option "Abonniert von" noch mit dem Benutzerkonto verknüpft. Notieren Sie sich die Benutzer mit den Abonnements und registrieren Sie sich unter dem neuen Inhaltseigentümer erneut für das Abonnement.

Wenn ein Benutzer eine Ansicht abonniert hat und diese dann nicht mehr lizenziert, bleibt sein Abonnement bestehen, aber die E-Mail wird nicht gesendet.  Wenn bei einer sehr großen Benutzerbasis der nicht lizenzierte Benutzer der einzige Benutzer ist, der ein Abonnement erhält, ist es für die Serverleistung wichtig, das Abonnement dieses Benutzers zu löschen.  Tableau Server erledigt die Aufgabe, die E-Mail wird aber nicht gesendet. 
 

Ursache

Ein Benutzer kann nicht entfernt werden, wenn ihm Inhalte gehören. Dazu zählen auch Projekte, aber sie werden nicht lizenziert. Weitere Informationen finden Sie in der Tableau Cloud-Hilfe unter Entfernen von Benutzern vom Server.

Wenn Benutzer A im Falle eines Abonnements Benutzer B für ein Abonnement registriert, ist dieses Abonnement auf der Inhaltsseite von Benutzer A nicht sichtbar.  Benutzer A ist nicht berechtigt zu sehen, was ein bestimmter Benutzer abonniert hat.
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