KNOWLEDGE BASE

Error "Unable to connect to the data source" When Opening a View after Change of Ownership


Published: 09 Jan 2018
Last Modified Date: 16 May 2023

Issue

After a published workbook connected to a published data source has changed ownership, the following error may occur when non-admin users open the view:

Unable to connect to the data source.
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner.

DataServiceFailure
Unable to connect to the server "localhost". Check that the server is running and that you have access privileges to the request database.

Environment

  • Tableau Cloud
  • Tableau Server

Resolution

Republish the workbook with "Embedded Password" selected as the authentication method for the published data source.

Cause

Non-admin users who are denied permissions to connect to the published data source can only access the view if the workbook is published with Embedded Password authentication. This allows the viewer to use the publisher's data source permissions to access the data, instead of their own.

If you change the ownership of a workbook or data source that has embedded credentials, the embedded credentials will be deleted. You can update the embedded credentials by editing the connection information on Tableau Cloud. For more information, see Edit Connections. Alternatively, you can download the workbook or data source, update the embedded credentials for the new owner, and then re-upload the workbook or data source.
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