KNOWLEDGE BASE

Fehler "Unable to connect to the data source" oder "User(s) do not have permission to access datasource" beim Zugreifen auf veröffentlichte Arbeitsmappen


Veröffentlicht: 18 Dec 2017
Zuletzt geändert am: 20 Jul 2023

Problem

Wenn Sie Ansichten öffnen, die veröffentlichte Datenquellen verwenden, tritt unter Umständen folgender Fehler auf:
 
"Unable to connect to the data source. (Verbindung mit Datenquelle nicht möglich.)
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner." (Wenn das Problem weiterhin besteht, trennen Sie die Verbindung zur Datenquelle und wenden Sie sich an den Besitzer der Datenquelle.)
Oder

"DataServiceFailure
Unable to connect to the server "localhost". Check that the server is running and that you have the access privileges to the requested database." (Prüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsberechtigungen für die angeforderte Datenbank haben.)

 
Oder
Benutzer haben keine Zugriffsberechtigungen für die Datenquelle.
There was an error with the data source "[DataSourceName]". (Es ist ein Problem mit der Datenquelle "[Datenquellenname]" aufgetreten.) Prüfen Sie, ob die Datenquelle ordnungsgemäß konfiguriert ist.

Umgebung

  • Tableau Cloud
  • Tableau Server

Lösung

Option 1

Vergeben Sie als Site-Administrator oder Eigentümer der Datenquelle für den betroffenen Benutzer die Berechtigung 'Verbinden' für die veröffentlichte Datenquelle. 

Option 2

Veröffentlichen Sie die Arbeitsmappe erneut und verwenden Sie Eingebettetes Kennwort für die veröffentlichten Datenquellen.
  1. Öffnen Sie die betroffene veröffentlichte Arbeitsmappe in Tableau Desktop. Eine Anleitung finden Sie unter Öffnen einer veröffentlichten Arbeitsmappe auf dem Server
  2. Veröffentlichen Sie die Arbeitsmappe erneut und stellen Sie sicher, dass unter Authentifizierung für alle veröffentlichten Datenquellen die Einstellung Eingebettetes Kennwort festgelegt ist. Weitere Informationen finden Sie unter Einrichten von Anmeldeinformationen für den Zugriff auf Ihre veröffentlichten Daten

Option 3

Speichern Sie die Arbeitsmappe erneut mit der Webdokumenterstellung und den eingebetteten Anmeldeinformationen. 
  1. Wenn Sie Autor der Arbeitsmappe oder Site-Administrator sind, bearbeiten Sie die Arbeitsmappe mit der Webdokumenterstellung. Eine Anleitung finden Sie unter Bearbeiten von Tableau-Ansichten im Internet.
  2. Wählen Sie Datei und dann Speichern unter...
  3. Vergeben Sie für die Arbeitsmappe den gleichen Namen wie für die bestehende Arbeitsmappe, um sie zu überschreiben. Wählen Sie dann das Feld Anmeldeinformationen für Datenquelle einbetten
  4. Wählen Sie Speichern.

Ursache

Der betroffene Benutzer verfügt nicht über die Berechtigungen, um eine Verbindung mit der veröffentlichten Datenquelle herzustellen, oder für einige der veröffentlichten Datenquellen in der Arbeitsmappe wurde die Option "Benutzer auffordern" anstelle von "Eingebettetes Kennwort" festgelegt. 
 
Hat dieser Artikel das Problem gelöst?