KNOWLEDGE BASE

Fehler "TableauException" oder "Could not find sheet with name: <SHEET>[0]" beim Veröffentlichen einer Arbeitsmappe auf Tableau Server oder/und Tableau Cloud


Veröffentlicht: 28 Jul 2017
Zuletzt geändert am: 20 Jul 2023

Problem

Nach dem Veröffentlichen einer Arbeitsmappe kann einer der folgenden Fehler auftreten:
 
Unknown server error (Unbekannter Serverfehler)
Es ist ein unerwarteter Fehler aufgetreten. If you continue to receive this error please contact your Tableau Server Administrator. (Ein unerwarteter Fehler ist aufgetreten. Wenn Sie weiterhin diese Fehlermeldung erhalten, wenden Sie sich an Ihren Tableau Server-Administrator.)
Session ID … (Es ist ein unerwarteter Fehler aufgetreten. Tritt dieser Fehler weiterhin auf, wenden Sie sich an Ihren Tableau Server-Administrator. Sitzungs-ID …) 
Would you like to reset the view? (Tableau-Ausnahme: Verbindung kann nicht hergestellt werden: Der erforderliche Kartenquellentyp wurde nicht lizenziert. Möchten Sie die Ansicht zurücksetzen?)


oder

Session Ended by Server: An unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator. Session ID: SESSION <HTML>(Sitzung durch Server beendet: Ein unerwarteter Fehler ist aufgetreten. Tritt dieser Fehler weiterhin auf, wenden Sie sich bitte an Ihren Tableau Server-Administrator. Sitzungs-ID: SESSION) <HEAD> <TITLE> Service Unavailable </TITLE> </HEAD> <BODY> <H1> Service Unavailable - Zero size object (Dienst nicht verfügbar – Nullgrößenobjekt)

oder
 
Uncaught Failed to re-initialize session (Nicht behobener Fehler beim erneuten Initialisieren der Sitzung)
 
Des Weiteren kann einer der folgenden Fehler auftreten:

TableauException: Error finding command parameter: yqf (Fehler bei Suche nach Befehlsparameter yqf)

oder
 
InvalidSheetIdException:​ Could not find sheet with name: <SHEET>[0] (InvalidSheetIdException:​ Blatt mit dem Namen <SHEET>[0] konnte nicht gefunden werden.)

Umgebung

  • Tableau Server
  • Tableau Desktop
  • Tableau Cloud
  • Benutzerdefiniertes SQL

Lösung

Es gibt ein paar mögliche Problemumgehungen:

Option 1

  1. Öffnen Sie die Arbeitsmappe in Tableau Desktop und gehen Sie zu der Datenquelle-Registerkarte.
  2. Kopieren Sie die ursprüngliche benutzerdefinierte SQL ohne zusätzliche Zeilen-Feed-Zeichen in einen Texteditor wie beispielsweise Notepad.
  3. Entfernern Sie Custom SQL aus der Datenquellen-Registerkarte in Tableau Desktop.
  4. Erstellen Sie erneut eine benutzerdefinierte SQL in der Datenquelle-Registerkarte in Tableau Desktop mit dem Text von Schritt 2.
  5. Wiederholen Sie Feldtypkonvertierungen wie ohne Datum in ein Datum oder Zeitdatum.
  6. Erstellen Sie das Arbeitsblatt und veröffentlichen Sie es auf Tableau Server.
Weitere Informationen zum Ändern des Felddatentyps finden Sie unter Konvertieren eines Felds in ein Datumsfeld in der Tableau-Hilfe.

Option 2

Vermeiden Sie die Verwendung des Symbols "<" durch Änderung der SQL-Anweisung. Zum Beispiel:

Von:  tableA.ActDate >= tableB.startDate AND tableA.ActDate <= tableB.endDate
Zu  :  tableA.ActDate BETWEEN tableB.startDate AND tableB.endDate


Option 3

Konvertieren Sie das Datumsfeld mit dem Datentyp STRING zu dem Datentyp DATE in der SQL-Anweisung. Zum Beispiel:

TO_DATE(tableA.ActDate,'YYYY/MM/DD') as ActDate

Ursache

Bei der Verwendung spezieller Sonderzeichen wie “<” in Custom SQL in Kombination mit einer Änderung eines Datenfeldtyps ohne Datum in ein Datum oder Zeitdatum werden zusätzliche Zeilen-Feed-Zeichen am Custom SQL-Anfang und -Ende sowie nach anderen zuvor vorhandenen Zeilen-Feed-Zeichen hinzugefügt.

Zusätzliche Informationen


 
Hat dieser Artikel das Problem gelöst?