KNOWLEDGE BASE

Fehler "Fehler ohne Verbindung (Statuscode =100000)" und "Kerberos RunAs-Authentifizierung unter Linux nicht aktiviert" bei Datenaktualisierung auf Cloud


Veröffentlicht: 03 May 2019
Zuletzt geändert am: 19 Jun 2023

Problem

Beim Aktualisieren einer veröffentlichten Datenquelle oder Arbeitsmappe mit der Tableau Cloud treten Fehler wie folgende auf: 

Connection Failure (status code = 10000) (Verbindungsfehler (Statuscode = 10000))
There was an unknown connection error to the database. (Unbekannter Verbindungsfehler zur Datenbank aufgetreten.)

Kerberos RunAs authentication not enabled on Linux. (Kerberos RunAs-Authentifizierung unter Linux nicht aktiviert.)
 

Umgebung

  • Tableau Cloud
  • Am Standort vorgehaltene Daten

Lösung

  • Wenn Ihre Daten vor Ort oder in der privaten Cloud bereitgestellt werden, verwenden Sie Tableau Bridge. Tableau Bridge ist eine separate, kostenlose Anwendung, die Sie auf einem Computer installieren, der Zugriff auf Ihre Daten hat. Bridge führt die Aktualisierung lokal aus und lädt dann den neuen Extrakt in Tableau Cloud hoch.

Hinweis: Tableau Bridge kann nur an individuell veröffentlichten Datenquellen verwendet werden und nicht an Datenquellen, die in einer Arbeitsmappe eingebettet sind. Um Datenquellen mithilfe von Bridge zu aktualisieren, veröffentlichen Sie die Arbeitsmappe erneut mit den separat veröffentlichten Datenquellen. Weitere Informationen finden Sie unter Einrichten eines Aktualisierungszeitplans mithilfe von Bridge.

Antworten auf häufig gestellte Fragen über Tableau Bridge finden Sie unter Häufig gestellte Fragen zu Tableau Bridge.

  • Wenn Ihre Daten in der öffentlich zugänglichen Cloud gehostet werden, besteht die Lösung aus zwei Teilen:

    1. Stellen Sie sicher, dass Sie die entsprechenden Tableau Cloud-IP-Adressen in eine Positivliste aufgenommen haben (siehe Beschreibung in Tableau Cloud-IP-Adressen für Datenanbieter-Autorisierung). Auf diese Weise kann Tableau Cloud auf die Datenbank zugreifen.
2. Wenn Sie eine Verbindung zur Datenquelle herstellen und diese veröffentlichen, verwenden Sie die Authentifizierung mit Benutzername/Kennwort, nicht die Windows-Authentifizierung. Da Tableau Cloud nicht auf Ihr Netzwerk oder Active Directory zugreifen kann, ist keine Authentifizierung mit der Windows-Authentifizierung möglich. Es müssen stattdessen der Benutzername und das Kennwort verwendet werden.

Ursache

Tableau Cloud kann nicht auf die vor Ort bereitgestellten Daten zugreifen oder die Windows-Authentifizierung für den Zugriff verwenden.  Das kann oft auftreten, wenn der Zeitplan für die Extraktaktualisierung nicht korrekt eingerichtet wurde.
 
 
Hat dieser Artikel das Problem gelöst?