KNOWLEDGE BASE

WDC Based Connections Fail When Using Proxy Configurations from PAC Files


Published: 07 Oct 2020
Last Modified Date: 09 Dec 2022

Issue

When attempting to connect Tableau Desktop to a WDC (Web Data Connection) data source a blank screen or o "Your Internet Access is blocked" message may appear.
Or, on Tableau Server, refreshing extracts connecting to WDC data source fails.

Environment

  • Tableau Desktop 2020.3.0 - 2020.3.1
  • Tableau Desktop 2020.2.0 - 2020.2.6
  • Tableau Desktop 2020.1.0 - 2020.1.9
  • Tableau Desktop 2019.4.0 - 2020.4.12
  • Tableau Server 2020.3.0 - 2020.3.1
  • Tableau Server 2020.2.0 - 2020.2.6
  • Tableau Server 2020.1.0 - 2020.1.9
  • Tableau Server 2019.4.0 - 2020.4.12
  • WDC based data sources

Resolution

Option 1

Upgrade to one of the following versions:
  • Tableau Desktop / Tableau Server 2020.3.2
  • Tableau Desktop / Tableau Server 2020.2.7
  • Tableau Desktop / Tableau Server 2020.1.10
  • Tableau Desktop / Tableau Server 2019.4.13

Option 2

Set proxy using hostname/IP and port instead of PAC.

Cause

Tableau change from using Webkit to WebEngine did not allow access for proxy configurations from .pac files.
This is a known issue that is addressed in more recent version of Tableau Desktop and Tableau Server.
 
Did this article resolve the issue?