ナレッジベース

ハード ディスクの空き容量が不足した後にいくつかのプロセスが起動できない


発行: 26 Aug 2020
最終修正日: 10 Jul 2023

問題

ディスク領域が不足し、領域を解放するかディスク領域をさらに拡張した後も、Tableau Server は DEGRADED (機能低下) と表示され続け、(ゲートウェイ、データ エンジン、Elastic Server などの) いくつかのプロセスがエラー状態です。

servicestate​.json で、それらのエラー状態プロセスの "currentState" が "INSTALL_FAILED" と表示される場合があります。 既定では、servicestate.json の場所は /var/opt/tableau/tableau_server/data/tabsvc/tabadminagent/0/servicestate.json です。

    "hyper_0.20202.20.0425.1206" : {
      "currentState" : "INSTALL_FAILED",
      "requestedState" : "ENABLED"
    },

    "elasticserver_0.20202.20.0425.1206" : {
      "currentState" : "INSTALL_FAILED",
      "requestedState" : "ENABLED"
    },

    "gateway_0.20202.20.0425.1206" : {
      "currentState" : "INSTALL_FAILED",
      "requestedState" : "ENABLED"
    },

環境

  • Tableau Server 2020.2

解決策

オプション 1:

servicestate.json でエラー プロセスの現在の状態を変更してみてください。

  1. Tableau Server を停止します (エラー プロセスを正常に停止できなかった場合は、無視して OS の再起動を実行します)。
    • tsm stop
  2. スクリプトによって TSM のサービスを停止します。
    • Linux: sudo /opt/tableau/tableau_server/packages/scripts.<ビルド番号>/stop-administrative-services
    • Windows: C:\Program Files\Tableau\Tableau Server\packages\scripts.<ビルド番号>\stop-administrative-services.cmd
  3. servicestate.json を手動で編集し、すべてのプロセスの現在の状態が "currentState" : "ENABLED" であることを確認します。 requestedState についても同様です。既定では、servicestate.json は次のディレクトリにあります。
    • Linux: /var/opt/tableau/tableau_server/data/tabsvc/tabadminagent/0/servicestate.json
    • Windows: C:\ProgramData\Tableau\Tableau Server\data\tabsvc\tabadminagent\0\servicestate.json
  4. OS を再起動します。
  5. TSM のサービスが自動的に起動したかどうか確認します。
    • tsm status -v
  6. TSM のサービスが自動的に起動しなかった場合、スクリプトによって TSM のサービスを起動します。
    • Linux: sudo /opt/tableau/tableau_server/packages/scripts.<ビルド番号>/start-administrative-services
    • Windows: C:\Program Files\Tableau\Tableau Server\packages\scripts.<ビルド番号>\start-administrative-services.cmd
  7. Tableau Server を起動します。
    • tsm start
  8. Tableau Server のステータスが "RUNNING" であるかどうか確認します。
    • tsm status -v
  9. いくつかのプロセスがまだエラー状態の場合は、もう 1 ~ 2 回 Tableau Server を再起動してみてください。
    • tsm restart
 

オプション 2:

クリーン インストールを実行してから、同じマシンでデータを復元します。
  1. バックアップを作成し、手動でのアクションが必要なアセットを集めます。 「Backing up Tableau Server for recovery」(リカバリに備えた Tableau Server のバックアップ) を参照してください。
  2. バックアップ ファイル (.tsbak、.json) を、Tableau Server と無関係なディレクトリにコピーします。
  3. サーバー ライセンスを削除せずに Tableau Server を完全に削除します。「サーバー ライセンスを削除せずに Tableau Server を完全に削除するには」を参照してください。
  4. 同じバージョンの最新のメンテナンス リリースをインストールします。製品のダウンロードとリリース ノートで、最新のメンテナンス リリースを検索してください。
  5. Tableau Server のコア機能を復元し、他の機能を復元します。「Tableau Server の完全バックアップとリストアを実行する」を参照してください。

原因

ディスク領域が不足して一部のプロセスが degraded (機能低下) ステータスになった後、場合によっては、ディスクの問題が解決した後も Tableau Server でプロセスのステータスが正確に識別されず、誤った servicestate.json ファイルが生成されることがあります。

詳細情報

この問題を防ぐために、空きディスク領域を監視し、ディスク領域不足のメール通知を有効にしてください。 詳細については、「サーバー イベント通知の構成」を参照してください。
この記事で問題は解決しましたか?