BASE DE CONNAISSANCES

Nœuds Tableau Server bloqués en état d'erreur après le redémarrage de TSM


Date de publication : 30 Jan 2019
Date de dernière modification : 08 Apr 2024

Problème

Après le redémarrage d'un cluster Tableau Server, les nœuds risquent d'être bloqués dans un état d'erreur et TSM ne peut pas démarrer. L'erreur TabsvcHandler suivante est consignée :
   
+ \logs.zip\logs\tabsvc\tabsvc_node2-0.log:
 
2018-12-15 09:09:54.780 -0600  Thread-1 : INFO  com.tableausoftware.tabsvc.TabSvcHandler - Resurrection data file path set to (Chemin d'accès du fichier de données de résurrection défini sur) : F:\Tableau Server\data\tabsvc\tabsvc\0\tabsvc-service-resurrection-data_tabsvc-clusterid.json
2018-12-15 09:09:54.780 -0600  Thread-1 : INFO  com.tableausoftware.tabsvc.TabSvcHandler - Found resurrection data file (Fichier de données de résurrection trouvé) F:\Tableau Server\data\tabsvc\tabsvc\0\tabsvc-service-resurrection-data_tabsvc-clusterid.json. Will now try to resurrect the services. (Va maintenant essayer de ressusciter les services)
2018-12-15 09:09:54.785 -0600  Thread-1 : ERROR(ERREUR) com.tableausoftware.tabsvc.TabSvcHandler - Failed to load resurrection data file (Échec de chargement du fichier de données de résurrection) : F:\Tableau Server\data\tabsvc\tabsvc\0\tabsvc-service-resurrection-data_tabsvc-clusterid.json
        java.lang.RuntimeException: com.fasterxml.jackson.databind.JsonMappingException : aucun contenu à mapper en raison de la fin de l'entrée

Environnement

  • Windows Server 2012 et 2016
  • Tableau Server avec TSM (toutes les versions actuelles)

Résolution

Supprimez les nœuds défectueux du cluster, réinstallez Tableau Server sur les nœuds et ajoutez de nouveau les nœuds au cluster.
  1. Supprimez les nœuds en état d'erreur à l'aide de l'interface utilisateur TSM, ou en utilisant la topologie TSM de commande remove-nodes --node-names "node2". Le reste du cluster demeure dans un état opérationnel. 
  2. Facultatif : créez une sauvegarde de vos données avant de supprimer Tableau, et enregistrez le fichier de sauvegarde dans un emplacement sécurisé sur un ordinateur qui ne fait pas partie de votre installation Tableau. Remarque : par défaut, les sauvegardes sont créées dans C:\ProgramData\Tableau\Tableau Server avec un nom du type « uninstall-2018.1.tsbak ». L'enregistrement des fichiers de sauvegarde sur un ordinateur séparé vous permet de réinstaller la version de Tableau Server qui a créé la sauvegarde et de disposer des données contenues dans la sauvegarde, même après avoir exécuté le script tableau-server-obliterate.
  3. Après avoir vérifié que toutes les données Tableau ont été sauvegardées sur le nœud, exécutez le script Tableau-Server-Obliterate sur chaque nœud défaillant du cluster, avec l'emplacement par défaut suivant : C:\Program Files\Tableau\Tableau Server\packages\scripts.<version_code>\tableau-server-obliterate.cmd -y -y –y
  4.  Réinstallez Tableau Server sur les nœuds souhaités en utilisant l'interface Web TSM ou l'interface en ligne de commande TSM.
Les étapes générales d'installation de Tableau Server sur un nœud supplémentaire sont les suivantes : 
a. Confirmer les prérequis
b. Générer le fichier Bootstrap du nœud 
c. Installer un nœud supplémentaire
d. Configurer un nœud supplémentaire
e. Installer les pilotes

Remarque : vous ne devriez ajouter et configurer des nœuds supplémentaires que lorsque vous pouvez exécuter le processus jusqu'au bout en appliquant les modifications en attente. Si vous ajoutez un nœud sans finir d'appliquer les modifications en attente, il se peut que les utilisateurs ne soient pas en mesure de se connecter à Tableau Server.
  1. Appliquez les modifications en attente et redémarrez Tableau Server.
  2. Vérifiez que les nœuds sont correctement ajoutés au cluster, en > affichant la page État de TSM ou la page État du serveur de l'interface utilisateur Web

Cause

Le fichier de résurrection tabsvc (tabsvc-service-resurrection-data-*.json) a été corrompu et ce fichier est responsable de l'instanciation de l'état d'exécution de tabsvc dans TSM.  Cela peut se produire lorsque l'espace disque est épuisé.  
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