KNOWLEDGE BASE

Errore "Unable to connect to the Microsoft Access database" o "Database error 0x80040154: Class not registered" durante la connessione ad Access 365


Pubblicato: 19 Dec 2018
Data dell'ultima modifica: 24 Aug 2022

Problema

Durante i tentativi di connessione a Microsoft Access 365, si verifica uno dei seguenti errori:

"An error occurred while communicating with Microsoft Access. Download and install the drivers and then connect" (Si è verificato un errore durante la comunicazione con Microsoft Access. Scarica e installa i driver e quindi esegui la connessione)

Unable to connect to the Microsoft Access database
"C:\Users\<username\Filepath\>accdb". Check that the path is correct and that you have access privileges for the requested file." (Impossibile connettersi al database di Microsoft Access "C:\Users\<username\Filepath\>accdb". Verifica che il percorso sia corretto e di disporre dei privilegi di accesso per il file richiesto.)

O

"The drivers required to connect to the data source are not installed. The error may need to be resolved through local configuration changes on the Tableau side. Database error 0x80040154: Class not registered Unable to connect to the Microsoft Access database "<filepath>.accdb". Check that the path is correct and that you have access privileges for the requested file." (I driver richiesti per connettersi all'origine dati non sono installati. Potrebbe essere necessario risolvere l'errore mediante modifiche alla configurazione locale sul lato di Tableau. Errore database 0x80040154: Classe non registrata - Impossibile connettersi al database Microsoft Access" "<filepath>.accdb". Verifica che il percorso sia corretto e di disporre dei privilegi di accesso per il file richiesto.)

L'errore si verifica dopo aver selezionato il nome del file nella connessione di Access in Tableau Prep o quando si tenta di creare una connessione in Tableau Desktop a Microsoft Access.

 

Ambiente

  • Tableau Prep
  • Tableau Desktop
  • Windows
  • Access 365

Soluzione

Opzione 1:

  1. Disinstalla il driver del motore di database di Microsoft Access, che verrà elencato in App e funzionalità o Programmi e funzionalità (in Disinstalla un programma). È probabilmente la versione a 32 bit del driver.
  2. Vai alla pagina dei driver di Tableau (http://tableau.com/support/drivers) e passa a Microsoft Access > Tableau Prep. Viene indicato che è necessario installare la versione a 64 bit del driver con Tableau Prep. Le istruzioni sono un po' più complesse per Tableau Desktop. 
  3. Fare clic sul collegamento nella pagina dei driver per passare a: https://www.microsoft.com/en-us/download/details.aspx?id=13255. Fai clic sul collegamento Download e assicurati di selezionare il pacchetto di download che contiene "x64". Installa questo driver.
  4. La connessione ora dovrebbe funzionare. Potrebbe essere necessario chiudere e riaprire Tableau Prep o Tableau Desktop per riflettere la modifica del driver.

Opzione 2:

  1. Se hai accesso a una versione più recente di Microsoft Access, carica il file .mdb nella versione più recente di Access.
  2. Seleziona File/Salva con nome e salvalo nel formato di file più recente, con estensione .accdb.  
  3. Chiudi Microsoft Access. 
  4. Apri Tableau e carica il file .accdb.

Opzione 3:

  1. Apri Tableau Desktop.
  2. Connettiti al file .mdb di Microsoft Access.
  3. Crea un'estrazione del file .mdb.
  4. Se usi Tableau Prep, utilizza la copia locale dell'estrazione come nodo di input in Tableau Prep.

Causa

È stata installata la versione a 32 bit del driver di Microsoft Access.
Con questo articolo hai risolto il problema?