BASE DE CONNAISSANCES

Erreur "Unable to connect to the Microsoft Access database" ou "Database error 0x80040154: Class not registered" lors de la connexion à Access 365


Date de publication : 19 Dec 2018
Date de dernière modification : 24 Aug 2022

Problème

Lors de la tentative de connexion à Microsoft Access 365, une des erreurs suivantes se produit :

"An error occurred while communicating with Microsoft Access. Download and install the drivers, and then connect. (Une erreur s'est produite lors de la communication avec Microsoft Access. Téléchargez et installez les pilotes, puis connectez-vous.)

Unable to connect to the Microsoft Access database
"C:\Users\<username\Filepath\>accdb". Check that the path is correct and that you have access privileges for the requested file." (Impossible de se connecter à la base de données Microsoft Access "C:\Users\<username\Filepath\>accdb". Vérifiez que le chemin est correct et que vous disposez des droits nécessaires pour accéder au fichier demandé.)

OU

"The drivers required to connect to the data source are not installed. The error may need to be resolved through local configuration changes on the Tableau side. Database error 0x80040154: Class not registered Unable to connect to the Microsoft Access database "<filepath>.accdb". Check that the path is correct and that you have access privileges for the requested file." (Les pilotes nécessaires pour se connecter à la source de données ne sont pas installés. Il se peut que vous deviez résoudre l'erreur via des modifications de configuration locale du côté de Tableau. Erreur de base de données 0x80040154 : Classe non enregistrée Impossible de se connecter à la base de données Microsoft Access ".accdb". Vérifiez que le chemin est correct et que vous disposez des droits nécessaires pour accéder au fichier demandé.)

L'erreur se produit après la sélection du nom de fichier dans la connexion à Access dans Tableau Prep ou lorsque vous tentez de créer une connexion dans Tableau Desktop vers Microsoft Access.

 

Environnement

  • Tableau Prep
  • Tableau Desktop
  • Windows
  • Access 365

Résolution

Option 1 :

  1. Désinstallez le pilote du moteur de base de données Microsoft Access qui apparaîtra également dans Applications et fonctionnalités (sous Désinstaller un programme).Il s'agit probablement de la version 32 bits du pilote.
  2. Accédez à la page Pilotes de Tableau (http://tableau.com/support/drivers) et accédez à Microsoft Access > Tableau Prep. Il est indiqué que la version 64 bits du pilote doit être installée avec Tableau Prep. Les instructions sont un peu plus complexes pour Tableau Desktop. 
  3. Cliquez sur le lien dans la page des pilotes pour accéder à https://www.microsoft.com/fr-fr/download/details.aspx?id=13255. Cliquez sur le lien Télécharger et veillez à sélectionner le package de téléchargement contenant « x64 ». Installez ce pilote.
  4. La connexion devrait maintenant fonctionner. Il peut être nécessaire de fermer et d'ouvrir Tableau Prep ou Tableau Desktop pour refléter le changement de pilote.

Option 2 :

  1. Si vous avez accès à une version plus récente de MS Access, chargez le fichier .mdb dans cette nouvelle version de Access.
  2. Sélectionnez Fichier/Enregistrer sous et enregistrez-le en tant que nouveau type de fichier .accdb. 
  3. Fermez MS Access. 
  4. Ouvrez Tableau et chargez le fichier .accdb.

Option 3 :

  1. Ouvrez Tableau Desktop.
  2. Connectez-vous à votre fichier MS Access .mdb.
  3. Créez un extrait de ce fichier .mdb.
  4. Si vous utilisez Tableau Prep, utilisez la copie locale de l'extrait en tant que nœud d'entrée dans Tableau Prep.

Cause

La version 32 bits du pilote Microsoft Access a été installée.
Cet article vous a-t-il permis de résoudre le problème ?