KNOWLEDGE BASE

Fehler "Unable to connect to the Microsoft Access database" oder "Database error 0x80040154: Class not registered" beim Herstellen der Verbindung mit Access 365


Veröffentlicht: 19 Dec 2018
Zuletzt geändert am: 24 Aug 2022

Problem

Bei dem Versuch, eine Verbindung mit Microsoft Access 365 herzustellen, wird einer der folgenden Fehler angezeigt:

"An error occurred while communicating with Microsoft Access. Download and install the drivers and then connect

Unable to connect to the Microsoft Access database
"C:\Users\<username\Filepath\>accdb". Check that the path is correct and that you have access privileges for the requested file." (Fehler beim Kommunizieren mit Microsoft Access. Laden Sie die Treiber herunter, und installieren Sie sie. Stellen Sie anschließend eine Verbindung her. Herstellen der Verbindung zur Microsoft Access-Datenbank nicht möglich. "C:\Users\<username\Filepath\>accdb". Überprüfen Sie, ob der Pfad richtig ist und ob Sie zum Zugriff auf die angeforderte Datei berechtigt sind.)

ODER

"The drivers required to connect to the data source are not installed. The error may need to be resolved through local configuration changes on the Tableau side. Database error 0x80040154: Class not registered Unable to connect to the Microsoft Access database "<filepath>.accdb". Check that the path is correct and that you have access privileges for the requested file." (Die zum Herstellen der Verbindung mit der Datenquelle erforderlichen Treiber sind nicht installiert. Der Fehler muss möglicherweise durch lokale Konfigurationsänderungen auf der Tableau-Seite behoben werden. Datenbankfehler 0x80040154: Klasse nicht registriert. Herstellen der Verbindung mit der Microsoft Access-Datenbank "<filepath>.accdb" nicht möglich. Überprüfen Sie, ob der Pfad richtig ist und ob Sie zum Zugriff auf die angeforderte Datei berechtigt sind.)

Der Fehler wird nach Auswahl des Dateinamens in der Access-Verbindung in Tableau Prep oder bei dem Versuch, eine Verbindung zwischen Tableau Desktop und Microsoft Access herzustellen, angezeigt.

 

Umgebung

  • Tableau Prep
  • Tableau Desktop
  • Windows
  • Access 365

Lösung

Option 1:

  1. Deinstallieren Sie den Microsoft Access-Datenbankmodul-Treiber, der unter "Apps und Features" oder "Programme und Features" (unter "Programm deinstallieren") aufgelistet ist.Es handelt sich wahrscheinlich um die 32-Bit-Version des Treibers.
  2. Rufen Sie die Seite für die Tableau-Treiber (http://tableau.com/support/drivers) auf, und navigieren Sie zu "Microsoft Access" > "Tableau Prep". Dies besagt, dass die 64-Bit-Version des Treibers mit Tableau Prep installiert werden muss.Die Anweisungen für Tableau Desktop sind etwas komplexer.
  3. Klicken Sie auf der Treiberseite auf den Link, um zu https://www.microsoft.com/de-de/download/details.aspx?id=13255 zu navigieren. Klicken Sie auf den Downloadlink, und stellen Sie sicher, dass im Namen des Downloadpakets "x64" enthalten ist. Installieren Sie diesen Treiber.
  4. Nun sollte die Verbindung funktionieren.Damit der geänderte Treiber berücksichtigt wird, müssen Sie Tableau Prep oder Tableau Desktop möglicherweise schließen und wieder öffnen.

Option 2:

  1. Wenn Sie über Zugriff auf eine neuere Version von MS Access verfügen, laden Sie die .mdb-Datei in die neuere Version von Access.
  2. Wählen Sie die Option zum Speichern der Datei, und speichern Sie sie als den neueren Dateityp .accdb. 
  3. Schließen Sie MS Access.
  4. Öffnen Sie Tableau, und laden Sie die .accdb-Datei.

Option 3:

  1. Öffnen Sie Tableau Desktop.
  2. Stellen Sie eine Verbindung mit Ihrer .mdb-Datei von MS Access her.
  3. Erstellen Sie einen Extrakt dieser .mdb-Datei.
  4. Verwenden Sie bei Nutzung von Tableau Prep die lokale Kopie des Extrakts als einen Eingabeknoten in Tableau Prep.

Ursache

Es wurde die 32-Bit-Version des Microsoft Access-Treibers installiert.
Hat dieser Artikel das Problem gelöst?