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Error "Unable to connect to the Microsoft Access database" or "Database error 0x80040154: Class not registered" Connecting to Access 365


Published: 19 Dec 2018
Last Modified Date: 24 Aug 2022

Issue

When attempting to connect to Microsoft Access 365, one of the following errors occurs:

"An error occurred while communicating with Microsoft Access. Download and install the drivers and then connect

Unable to connect to the Microsoft Access database
"C:\Users\<username\Filepath\>accdb". Check that the path is correct and that you have access privileges for the requested file."

OR

"The drivers required to connect to the data source are not installed. The error may need to be resolved through local configuration changes on the Tableau side. Database error 0x80040154: Class not registered Unable to connect to the Microsoft Access database "<filepath>.accdb". Check that the path is correct and that you have access privileges for the requested file."

The error occurs after selecting the filename in the Access connection in Tableau Prep or when trying to create a connection in Tableau Desktop to Microsoft Access.

 

Environment

  • Tableau Prep
  • Tableau Desktop
  • Tableau Server
  • Windows
  • Access 365

Resolution

Option 1:

  1. Uninstall the Microsoft Access Database Engine driver which will be listed in Apps & Features or Programs & Features (under Uninstall a program). It is probably the 32-bit version of the driver.
  2. Go to Tableau Drivers page (http://tableau.com/support/drivers) and navigate to Microsoft Access > Tableau Prep. It says that the 64-bit version of the driver must be installed with Tableau Prep. The instructions are a bit  more complex for Tableau Desktop. 
  3. Click on the link on the drivers page to go to: https://www.microsoft.com/en-us/download/details.aspx?id=13255. Click on the Download link and make sure to select the download package that has "x64" in it. Install this driver.
  4. The connection should now work. It may be necessary to close and open Tableau Prep or Tableau Desktop to reflect the changed driver.

Option 2:

  1. If you have access to a newer version of MS Access. load the .mdb file into that newer version of Access.
  2. Select File/Save-As and save it as the newer file type .accdb.  
  3. Close MS Access. 
  4. Open Tableau and load the .accdb file.

Option 3:

  1. Open Tableau Desktop.
  2. Connect to your MS Access .mdb file.
  3. Create an extract of that .mdb file.
  4. If using Tableau Prep, use the local copy of the extract as an input node in Tableau Prep.

Option 4:

  1. On Tableau Server host machine, go to Control Panel > Programs & Features, check if the Microsoft Access Database Engine driver is installed. If it's not installed or If it's installed but it's for 32-bit, go to #2. 
  2. Go to Tableau Drivers page (http://tableau.com/support/drivers), and select 'Microsoft Access' for Driver and select the right OS type with 64-bit.
  3. Find 'Tableau Server' and Click on the link on the drivers page to go to: https://www.microsoft.com/en-us/download/details.aspx?id=13255. Click on the Download link and make sure to select the download package that has "x64" in it. Install this driver.
  4. The connection should now work. It may be necessary to re-login to Tableau Server and access the published workbook. 

Cause

The 32-bit version of the Microsoft Access driver was installed.
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