知識庫

啟用 Tableau Prep 時發生內部授權錯誤


發佈時間 : 19 Nov 2018
上次修改日期 : 20 Jul 2023

問題

啟動 Tableau Prep 時,可能會出現以下錯誤:
The product is unable to activate due to an internal licensing error.Contact your System Administrator.(請聯絡您的系統管理員。)

環境

Tableau Prep

解決方法

選項 1:驗證 FlexNet Licensing Service 正在執行

Windows

  1. 從 Windows [開始] 選單,開啟 [services.msc]

  2. 在 [服務] 對話方塊中,確定 FlexNet Licensing Service 的狀態為 [已開始]

    附註:「開始」選項為灰色,請以右鍵按一下清單中的「FlexNet 授權服務」,然後選取「屬性」。在 [一般] 索引標籤中按一下 [開始],然後按一下 [確定] 關閉對話框。

Mac

  1. 開啟 Terminal 應用程式。

  2. 導覽到 FlexNet 目錄:

    '/Applications/Tableau Desktop <Tableau version.app>/Contents/Frameworks/FlexNet/'custactutil -view

    例如 '/Applications/Tableau Desktop 2018.2.app/Contents/Frameworks/FlexNet/'custactutil -view

驗證 FlexNet Licensing Service 正在執行。您應該會看到Trust Flags = FULLY TRUSTED and Status = ENABLED

選項 2 

確認用於啟用的授權金鑰為「Creator - Desktop & Prep」授權金鑰,且開頭為「TC」。  Desktop Professional 金鑰 (開頭為字母「TD」) 與 Tableau Prep 不相容。

選項 3 (僅限 Windows):確認 FNPLicensingService64.exe 的版本低於 11.16.2.3

1.瀏覽至 FNPLicensingService64.exe 檔案 (C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe)
2.以右鍵按一下 exe 檔,然後選擇「屬性」。
​​​​​​​3.按一下「詳細資料」索引標籤,確認「檔案版本」顯示 11.16.2.3

原因

未執行 Tableau 使用的 FlexNet Licensing Service 。

其他資訊


這篇文章是否解決了問題?