KNOWLEDGE BASE

Workbook Displays Blank After Republishing Data Source


Published: 09 Mar 2017
Last Modified Date: 10 Mar 2017

Issue

When republishing a data source, other workbooks which connect to the same published data source may be blank.

Opening the affected workbook in Tableau Desktop may contain invalid fields with the following error: 

The field [...] does not exist in the database. 

Environment

  • Tableau Online
  • Tableau Desktop
  • Tableau Server
  • Published Data Source 
  • Tableau Data Server

Resolution

Download the published copy of the data source and make changes which will not affect other workbooks before republishing. 
  1. Open Tableau Desktop. 
  2. Under Connect, select Tableau Server
  3. If prompted, sign-in to the server. 
  4. Hover your cursor over the desired data source, then select the down arrow to download a local copy of the connection. 
  5. Make the necessary changes to the data source that will not affect existing workbooks, then republish and overwrite the connection. 

Cause

Calculations and other forms of metadata can be stored in the published data source, rather than the workbook. Republishing and overwriting an existing data source with a version that does not contain the metadata used in existing workbooks, may result in an error or blank workbook. 
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