KNOWLEDGE BASE

Using Action Filters Does Not Work As Expected on a Dashboard


Published: 05 Dec 2016
Last Modified Date: 03 Oct 2017

Issue

When using filters in a dashboard, the filters are not applied as expected. 

Environment

Tableau Desktop

Resolution

Navigate to the affected sheets in Tableau Desktop and remove all redundant filter actions from the Filters shelf (i.e. all fields marked with "Action").

Cause

Some sheets may not be filtering because they have other filter actions applied to them (including filter actions coming from deleted dashboards). Filter actions originating from other dashboards (including dashboards that have been deleted) will "hang on" to the sheets, and may affect filter actions coming from the current dashboard. 
Did this article resolve the issue?