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Upgrading Tableau Server Backup Primary 'Worker is not responding' error


Published: 11 Jun 2015
Last Modified Date: 07 Mar 2017

Issue

When upgrading the Tableau Server backup primary, users may encounter the following errors when attempting to run commands or save configuration changes.

Worker <worker name> is not responding
Worker <worker name> is not responding
Confirm that the workers are installed, running, and configured with the computer name or all IPv4 addresses belonging to the primary Tableau Server

Environment

  • Tableau Server
  • High availability with backup primary

Resolution

Clean re-install the backup primary and follow the steps to configure the backup primary exactly as outlined in the Administrator Guide.

Cause

The failover process has not completed, so the backup primary is not recognized as the primary on the worker machines and the connection is refused.
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