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Unable To Refresh Web Data Connector Extract in Tableau Server


Published: 29 Oct 2015
Last Modified Date: 30 Jun 2016

Issue

When refreshing an extract of a data source that uses the web data connector, the extract refresh fails with "unknown failure". The Server Administrator can find additional details under Server > Status > Background Tasks for Extracts, the tooltip for the extract refresh shows:

Connection to an untrusted web data connector <URL> is not allowed. The table "[TableauTemp].[webdata-direct.<etc>]" Does not exist. Unable to connect to the server.

Environment

  • Tableau Server 9.1, 9.2, 9.3
  • Web data connector

Resolution

Step 1: Confirm that the web data connector has been imported into Tableau Server.

  1. From the Tableau Server bin folder, run the following command: tabadmin list_webdataconnectors --urls.
  2. Confirm that all portions of the web data connector are present, including .html, .js, and any supporting image or .css files. 
  3. If all components of the web data connector are listed among the urls, note the url of the .html and move on to Step 2.
  4. If any components are not listed among the urls, import the web data connector files. If re-importing any files, use --overwrite. See Web Data Connectors in Tableau Server for more information.

Step 2: From Tableau Desktop, connect to the imported web data connector

  1. Obtain the URL of the imported connector from the results of tabadmin list_webdataconnectors --urls or from the message displayed after running tabadmin import_webdataconnector. The URL should match the format of the following example: http://myserver/webdataconnectors/my_wdc.html
  2. In Tableau Desktop, connect to the web data connector using the URL. For more information, see Web Data Connector.
  3. Publish the data source. 

Cause

Web data connector extracts created from sources (i.e. web servers) other than Tableau Server cannot be refreshed.
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