KNOWLEDGE BASE

Unable to connect to SAP BW 7.4


Published: 30 Oct 2017
Last Modified Date: 30 Oct 2017

Issue

When attempting to connect Tableau Desktop to SAP BW 7.4, receives errors which may include:

"0x80040E4D: Authorization Failed"

Environment

  • Tableau Desktop
  • SAP BW 7.4

Resolution

SAP BW 7.4 uses a new connection information storage instead of saplogon.ini, which is SAPUILandscape.xml. In order for Tableau to recognize this and log onto SAP BW 7.4 properly, it requires a newer version of the driver (4.0.0.7 and above):
  • Download and install newest SAP BW driver.

Cause

Older drivers (pre 4.0.0.7) do not support using SAPUILandscape.xml for SAP connections.

Additional Information

The SAP BW driver must also match the bitness of the Tableau Desktop installation. If there are multiple versions installed, the driver will default to the 32-bit version. Make sure that the correct driver, in the correct bitness, is present, and there are no extra SAP BW drivers.
Did this article resolve the issue?