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Unable to Connect to DataStax Enterprise


Published: 30 Aug 2013
Last Modified Date: 21 Aug 2015

Issue

Unable to connect to DataStax Enterprise.

Environment

  • Tableau Desktop
  • DataStax Enterprise
  • Cassandra ODBC driver

Resolution

Use one of the following workarounds.

Option 1: Connect using the supported driver

If you are using DataStax Enterprise 2.2 or later, connect using the native data connection of the DataStax ODBC Driver for Hive (32-bit). This driver is available for download from the Tableau Drivers & Activation page.

Option 2: Connect using Cassandra and Other Databases (ODBC) connection

If you must use the Cassandra driver, it may be possible to connect to DataStax using the Other Databases (ODBC) data connection.

Warning: Although it may be possible to connect to DataStax using the Cassandra driver and the Other Databases (ODBC) data connection, success often varies and full compatibility with Tableau features cannot be guaranteed. Refer to the following resources for additional information about the capabilities and limitations of connecting to unsupported data sources via the general-purpose ODBC:

Option 3: Create an extract using the Tableau Data Extract API

Use the Tableau Data Extract API, which will allow you to connect to a data source that is not currently supported and extract data into a Tableau Data Extract (.tde) file. You can connect to the data extract from Tableau Desktop or publish the extract to Tableau Server. For more information, see Tableau Data Extract API in Tableau Help.

Cause

Cassandra ODBC driver is not supported.
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