KNOWLEDGE BASE

Unable to Allocate New Licenses


Published: 09 Apr 2014
Last Modified Date: 16 Aug 2017

Issue

After you add Interactor licenses to Tableau Server, Tableau Server might not show the correct number of licenses, and you might not be able to allocate the new licenses to users.

Environment

  • Tableau Server
  • Windows operating system

Resolution

Option 1

  1. Sign in to the computer running Tableau Server with an account that has full administrative rights.
  2. On the computer running Tableau Server, open the Command Prompt window as an administrator, and run one of the following commands:
    • On a 32-bit computer: cd "C:\Program Files\Tableau\Tableau Server\[version]\bin"
    • On a 64-bit computer: cd "C:\Program Files (x86)\Tableau\Tableau Server\[version]\bin"
  3. At the command prompt, run the following commands in order:
    • tabadmin stop 
    • lmreread
    • tabadmin start

Option 2

  1. Stop Tableau Server. For more information, see tabdamin stop in Tableau Help.
  2. Restart the computer running Tableau Server.
  3. Start Tableau Server. For more information, see tabadmin start in Tableau Help.

Cause

The Windows Registry has not been updated to reflect the new product key.
Did this article resolve the issue?