KNOWLEDGE BASE
Errors "(50041, 41143, 34) LM_TS_CONNECTION FAILED" or "We were unable to deactivate the product" Activating or Deactivating Tableau Server
Published: 21 Nov 2017
Last Modified Date: 30 Mar 2018
Issue
Unable to deactivate or activate Tableau Server even though licensing.tableau.com is accessible and ports 27000-27009 are open.
The following errors might occur:
- com.tableausoftware.license.dll.ConnectException: Function flxActSvrReturnSend returned error (50041, 41143, 34) LM_TS_CONNECTION FAILED
Tableau could not connect to the licensing server or FlexNet Operations Server.
Verify the product key is correct and the primary or online licensing server can be accessed by ports 27000-27009 - We were unable to deactivate the product. Make sure you are connected to the internet and try again. Alternatively, save an activation file and go to http://www.tableau.com/activation to create the activation process.
Environment
- Tableau Server
- Security Software
Resolution
Option 1
Activate offline. For more information, see Activate Tableau Server Offline.
Option 2
Add the following domains to an exclusion list or whitelist for your firewall application:
- .thawte.com
- .symantec.com
- .conferdeploy.net
- .tblsft.com
- .symcd.com
- port 54443
Cause
Traffic inspection by a firewall like Palo Alto Networks, which is performing URL category filtering, is blocking any URLs that are attempting to tunnel to licensing.tableau.com or licensing.tableausoftware.com during the licensing process, unless they are whitelisted or added to the exclusion list.
Additional Information
Run a fiddler trace with https not decrypted, look at the traffic and what URLs are tunneling during the activation/deactivation attempts.