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Teradata Driver Error On OS X El Capitan


Published: 01 Oct 2015
Last Modified Date: 25 Nov 2015

Issue

When connecting to Teradata from OS X El Capitan the following error might occur:

The drivers necessary to connect to this database are not properly installed.

To connect to this database, perform the following steps:

Click the following link to go to download drivers: Download Drivers
Follow the instructions
Attempt to connect to the database again.


Detailed Error Message:
 

[iODBC][Driver Manager]dlopen(/Library/Application Support/teradata/client/ODBC/lib/tdata.dylib, 6): Library not loaded: libtdparse.dylib Referenced from: /Library/Application Support/teradata/client/ODBC/lib/tdata.dylib Reason: image not found
[iODBC][Driver Manager]Specified driver could not be loaded
Unable to connect to the server "XXX". Check that the server is running and that you have access privileges to the requested database.

Environment

  • Tableau Desktop
  • Mac OS X El Capitan

Resolution

Use the following workaround:
  1. Uninstall all existing Teradata Client items using Uninstall in Applications >Teradata Client directory.
  2. Restart the computer.
  3. Press Command-R to enter Recovery Mode while rebooting.
  4. Open Terminal and disable System Integrity Protection by typing csrutil disable.
  5. Restart the computer.
  6. Install Teradata Client tools.
  7. Restart the computer.
  8. Verify that Tableau can connect to Teradata.
  9. Restart the computer.
  10. Press Command-R to enter Recover Mode while rebooting.
  11. Open Terminal and enable System Integrity Protection by typing csrutil enable.
  12. Restart the computer.

Cause

The Teradata drivers have not been updated to support OS X El Capitan.
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