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Tableau Data Engine Error: 40353, 40409 or 40909 Refreshing a Published Extract


Published: 26 Oct 2017
Last Modified Date: 15 Nov 2017

Issue

When attempting to refresh a published extract, the refresh fails. 

In background tasks for extracts, one of the following errors might occur:
Tableau Data Engine Error: 40353: The operation completed successfully. - Semaphore::Acquire
Tableau Data Engine Error: 40909: Overlapped I/O operation is in progress. - Semaphore::Acquire​
Tableau Data Engine Error: 40409: The operation completed successfully. - Semaphore::Acquire

 
 

Environment

Tableau Server 10.2.5 - 10.2.6, 10.3.3 - 10.3.4 and 10.4.0

Resolution

Option 1:


As a Tableau Server Administrator, upgrade Tableau Server to 10.2.7, 10.3.5, 10.4.1, or newer.  For more information, see Upgrading Tableau Server.


Option 2:

As a workaround, increase the Data Engine session timeout value (in minutes) using the commands below. The value can be increased as needed.
On the computer running Tableau Server, open a command prompt as an administrator and navigate to the Tableau Server bin folder, then run the following commands:
tabadmin stop
tabadmin set dataengine.session_recv_timeout 360
tabadmin config
tabadmin start

Cause

This behavior is related to a known issue with ID 703885 that has been resolved in newer versions.
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