KNOWLEDGE BASE

Scheduled Extract Refreshes Are Delayed on Tableau Online


Published: 10 Feb 2015
Last Modified Date: 29 Mar 2016

Issue

When scheduled extract refresh tasks run on Tableau Online, they may be delayed or start later than expected. 

Environment

  • Tableau Online
  • Schedules

Resolution

Schedule the refresh task using the Online Data Sync Client, or Data Extract Command-Line Utility, as they use resources from your desktop machine, rather than Tableau Online. 

Option 1

Configure the extract to refresh using the Online Data Sync Client. For more information, see Quick Start: Keep On-Premises Data Fresh.

Option 2

  1. Create a .bat file for each extract using the "tableau refreshextract" command. For more information, see Automate Extract Refresh Tasks.
  2. Schedule the extract .bat files to run using Windows Task Scheduler. 

Cause

Because system resources are shared across all sites on Tableau Online, scheduled tasks may be delayed depending on the number of extract and subscription tasks scheduled and the resources available to execute those tasks.
Did this article resolve the issue?