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Error "SAML Authentication Failed, please contact the administrator" After Upgrading


Published: 08 Jun 2015
Last Modified Date: 07 Jan 2016

Issue

After upgrading Tableau Server from 8.x to 9.x, SAML Authentication might fail and the following error might occur:

SAML Authentication Failed, please contact the administrator.

Additionally, the following error can be found in the logs:
 
Incoming SAML message has no valid value for username attribute. Please verify ServiceProvider configuration in Identity Provider.
 

Environment

Tableau Server 9.0 and later versions

Resolution

Verify that the attribute for "wgserver.saml.idpattribute.username:" matches the attribute in the SAML Assertion, including case sensitivity. 
  1. On the Tableau Server computer, open a command prompt as an Administrator.
  2. Navigate to the Tableau Server bin directory.
  3. Run the following commands: 
    tabadmin stop 
    tabadmin set wgserver.saml.idpattribute.username "<attribute name>" 
    tabadmin config 
    tabadmin start

Cause

Tableau Server 9.0 introduced case sensitivity for the wgserver.saml.idpattribute.username attribute.
 
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