KNOWLEDGE BASE

Receiving Sync Client Errors While Refreshing Extract After Upgrading Tableau Desktop


Published: 21 Jan 2016
Last Modified Date: 27 Feb 2017

Issue

After upgrading Tableau Desktop to match the Tableau Online version, the Online Sync Client fails to refresh extracts with the following errors:

"Could not refresh the data source. If the issue persists, contact Tableau…"
Or
"Incorrect user name or password for this data source. Confirm that you have the appropriate permissions and re-enter your credentials"
Or
"Errors occurred while trying to load the data source <>. The load was not able to complete successfully. The file was created by a newer version of Tableau. Please contact Tableau Software to upgrade your version."

Environment

  • Tableau Online Sync Client
  • Tableau Desktop
  • Tableau Online

Resolution

​Try the following workaround options:

Option 1 Disable, exit, and restart the Sync Client 
  1. If Sync Client is running as a service (Run Continuously), select the Sync Client menu button and select Run only when logged on.
  2. Select the Sync Client menu and select Exit.
  3. Restart the Sync Client from the most recent version of Tableau Desktop. 
  4. If preferred, re-enable the Run Continuously mode.

Option 2 Unlink and reconfigure the Sync Client 
  1. Right-click on the Sync Client taskbar icon.
  2. Click Unlink Sync Client.
  3. Right-click on the Sync Client taskbar icon and select Sign Out.
  4. Open the new version of Tableau Desktop.
  5. Click on Server > Start Tableau Online Sync Client.
  6. Reconfigure data sources to refresh using the Sync Client. 

Cause

The problem occurs when installing a new major version of Tableau Desktop while Sync Client is running (e.g. using version 9.0 and installing version 9.1). If Sync Client is not unlinked, it will restart the wrong version of the client after a computer reboot.

Additional Information

To verify which version of the Online Sync Client is running:
  1. Login to the computer running the Online Sync Client.
  2. Open the Task Manager window.
  3. Click the Processes tab.
  4. Right-click the TabOnlineSyncClient.exe and select Properties.
The General tab will display the file location to identify what version of Sync Client is running. For a deeper analysis, the Details tab will display the specific file version being used.
Did this article resolve the issue?