KNOWLEDGE BASE

Published Data Source Was Refreshed by Sync Client but Workbook Does Not Display New Data


Published: 26 Feb 2016
Last Modified Date: 03 Jun 2016

Issue

When opening a workbook connected to a published data source that is successfully refreshed by the Tableau Online Data Sync Client, the workbook might not display new data.

Environment

  • Tableau Online
  • Published data source
  • Sync Client

Resolution

Ensure that the workbook is connected to a published extract of the data source and not a local extract.
  1. Connect to published version of the extract (Data > New Data Source > Tableau Server (enter online.tableau.com) > Choose published version of extract)
  2. Right click the data source name and choose "Replace Data Source" - Replace local version with published version.
  3. Blue check mark indicating primary data source should move to the published (white square icon.)
  4. Right click local data extract and "close."
  5. Republish workbook to Tableau Online overwriting the previous version. 

Cause

Workbook is connected to a local extract of the data source and not the published extract that is refreshed with the Sync Client.
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