KNOWLEDGE BASE

Error "Internet communication error: Failure when receiving data from the peer" Creating a Salesforce Extract


Published: 10 May 2016
Last Modified Date: 26 Nov 2017

Issue

When creating a Salesforce data extract, the following error message might occur:

Internet communication error: Failure when receiving data from the peer - Unable to create extract

Environment

  • Tableau Desktop 9.2.8, 9.3.2 and earlier versions
  • Salesforce
  • Tableau online 

Resolution

Option 1

For versions 9.2.8, 9.3.2 and earlier of Tableau Desktop, upgrade to Tableau Desktop 9.2.9, 9.3.3 or a newer version. For more information, see Upgrading Tableau Desktop.

Option 2

As a workaround, or if using Tableau Online, use a .tdc file to increase the buffer size of the Salesforce connection:
  1. Open a new document in a text editor. 
  2. Enter information similar to the following:
    <?xml version='1.0' encoding='utf-8' ?>
    <connection-customization class='salesforce' enabled='true' version='10.3'>
      <vendor name='salesforce' />
      <driver name='salesforce' />
           <customizations>
              <!-- The valid value is between 32 to 1024 -->
              <customization name='sf-total-requestor-buffer-size-in-mb' value='1024' />
           </customizations>
    </connection-customization>
    
  3. Save the file with a .tdc extension -- for example, salesforce.tdc -- and place it in Datasources folder inside your My Tableau Repository folder.
Note: TDC files require careful hand editing, and are outside the scope of what Tableau Support can assist you with.

Cause

This behavior is related to a known issue which has been corrected in more recent versions.
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