KNOWLEDGE BASE

Scheduled Extract Does Not Refresh on Schedule But Can Be Run Manually


Published: 11 Mar 2014
Last Modified Date: 09 Aug 2017

Issue

When scheduling a task, such as refreshing an extract, the task might not run as scheduled. Manually running the task or refreshing the extract occurs without issue.

Environment

Tableau Server

Resolution

  1. Ensure that the Tableau Server Run As User has Modify, Read and Execute permissions for the following folders: 
    • C:\ProgramData\Tableau 
    • C:\Program Files\Tableau 
  2. Verify that the Run As User has Log on as a Service permission in the Local Security Policy.

Cause

The Tableau Server Run As User has insufficient permissions to start the schedule.

Additional Information

The following error might also be logged as a Background Task error:

com.tableausoftware.nativeapi.dll.DataSourceExceptoin: Unable to connect to the file "<file name>". Check that the file exists and that you have sufficient access privileges for it.
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