KNOWLEDGE BASE

Errors: "Unknown Server Error" or "Unexpected Server Error" When Accessing a Workbook Published on Tableau Server Hosted on AWS


Published: 09 Dec 2015
Last Modified Date: 20 Oct 2016

Issue

When accessing a workbook on Tableau Server hosted on AWS, the workbook fails to load and the following error messages might occur: 
Unknown Server Error
'An unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator.'
Or
Unexpected Server Error
'An error occurred communicating with the server (504). This may be a temporary network condition. Please retry the operation. If this condition persists, contact your system administrator.'

Environment

  • Tableau Server 9.0
  • AWS cloud server

Resolution

Increase the idle timeout on the AWS elastic load balancer. The default value is 60 seconds which can be increased up to 3600 seconds (1 hour).

Cause

The connection to AWS times out due to timeout settings in the elastic load balancer. For more information about Load Balancer, see 
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