KNOWLEDGE BASE

Errors "The credentials have been updated" Or "Tableau has been logged out by server" Refreshing Extracts Using Sync Client


Published: 31 May 2016
Last Modified Date: 26 Jun 2017

Issue

When running the Sync Client application as a service using "Run Continuously" to refresh extracts, you may be repeatedly logged out of the Sync Client with the below messages: 
 
The credentials have been updated. Please login again. 

Or 
 
Tableau has been logged out by server. Please login again. 

Environment

  • Sync Client 9.3.0 - 10.2 
  • Run Continuously 
  • Tableau Online

Resolution

Option 1
Upgrade Tableau Desktop/Bridge to version 10.3 or newer. See Upgrade Tableau Desktop for information on upgrading Tableau Desktop. 

To workaround the issue in an earlier version of Tableau Sync Client, try the following options: 

Option 2 Disable Run Continuously.  
1. Login to the Sync Client application. 
2. Select Run only when logged on in the upper right corner. 

Option 3 Switch the Tableau Online user account authentication type to TableauID. See Configure User Authentication for details. 

Cause

This behavior is related to a known issue with ID 519064 which has been corrected in more recent releases.

Additional Information

The issue may only occur when using a Tableau Online user account which is configured for SAML (Single Sign-on). 
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