KNOWLEDGE BASE

Error "Workers not responding" During Failover Testing


Published: 10 Apr 2014
Last Modified Date: 16 Feb 2016

Issue

When configuring a highly available environment, when you try to test the failover for the backup primary, the workers continue to recognize the original primary as the current primary, and the following error might occur:
 
Unable to stop worker <number>
Error: Workers not responding

Environment

  • Tableau Server 8.1.4  - 8.1.6
  • Tableau Server 8.0.8 - 8.0.10
  • Highly available environment

Resolution

Make sure you are using the correct syntax for the failoverprimary command. For more information, see Configure a Backup Primary in Tableau Help.

Cause

Adding multi-IP support resulted in a new syntax for the failoverprimary command. 
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