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Licensing Service Not starting resulting in "worker initialization failed"


Published: 29 Aug 2016
Last Modified Date: 15 Mar 2017

Issue

When upgrading to Tableau Server 9.3.0, 10.0.0 or later, configuration might fail and the following error message might occur:

Worker Initialization failed

Additionally, the following error message appears in the tabadmin.log:
 
"Service 'tablicsrv' failed to start (state 1)"
Or:
"Unable to start service 'tablicsrv': (5) Access is denied"

Environment

  • Tableau Server 9.3.x, 10.x
  • Non-default installation location 

Resolution

Ensure the Run As User Account adequate permissions to the drive where Tableau Server is installed, as well as to all of the contents of the Tableau Server sub folders.

Ensure that adequate permissions for the 'Local Service' account are set for the root of the drive where Tableau Server is installed.  


 

Cause

The Local Service account did not have the necessary permissions to complete the installation process.

Additional Information

With Tableau Server 9.3.0 and later, the account used for the Tableau License Service was changed to run under the Local Service account.  In many environments this account is not granted permissions on non-operating system drives. Setting permissions for the Local Service account to "Full Control" will correct this issue.

 
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