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Error "Unable to determine if all components of the service started properly" When Installing or Starting Tableau Server


Published: 04 Aug 2017
Last Modified Date: 08 Jan 2018

Issue

When attempting to start or install Tableau Server, the following error might occur: 
"Unable to determine if all components of the service started properly."

Additionally, when looking at TabAdmin logs, you may find the following two errors:
  • Error: Error deploying new vizportal war file. Running processes may be using these files. Make sure Server is stopped before trying this again. If this is happening during an installation, cancel the installation, uninstall Tableau Server, and then reboot Windows before trying again to ensure any orphaned processes are stopped. - Permission denied - D:/Program Files/Tableau/Tableau Server/data/tabsvc/vizportal/0/webapps/vizportal.war
  • __Waiting for component on 8600 to become ready by requesting http://localhost:8600/vizportal/check_status...
    __ No response from http://localhost:8600/vizportal/check_status: 404 Not Found__ Gave up on with_vizportal_ready or with_sitesaml_ready, No response from http://localhost:8600/vizportal/check_status: 404 Not Found file:/D:/Program Files/Tableau/Tableau Server/10.2/bin/tabadmin.jar!/lib/service.rb:1974:in `with_component_ready'

Environment

  • Tableau Server 
  • Windows Server 2012

Resolution

Option 1

Check that the Tableau Server Run As User has full control permissions. For more information, see Run As User and Troubleshoot Run As User.

Option 2

Disable any anti-virus that may preven applications from installing completely. See Before you install... in Tableau Help for additional considerations when installing Tableau Server. Please note that your Tableau Server Administrator may need to reinstall Tableau Server. See the following articles for more information: 

Cause

The Tableau Server Run As User does not have adequate permissions.
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