KNOWLEDGE BASE

Error "Unable to determine if all components of the service started properly ... Connection error contacting worker" Starting Worker


Published: 16 Dec 2015
Last Modified Date: 10 May 2016

Issue

When using tabcmd to start a worker node in a distributed environment, the following error might occur:

Unable to determine if all components of the service started properly. See
"tabadmin.log" for more information.
tableau-dev1:
Status: STOPPED
tableau-prd1.mtvn.ad.viacom.com:
Connection error contacting worker 1

Environment

  • Tableau Server 9.1.0
  • Windows Server 2012

Resolution

  1. Stop Tableau Server. 
  2. Shut down all of the computers running Tableau Server, primary and workers. 
  3. Restart the workers and wait until they boot up completely. 
  4. Restart the primary. 
If the above steps do not resolve this issue, restart the Tableau Service Application Manager on the worker node.

Cause

This behavior is related to a known issue that is currently under investigation.
Did this article resolve the issue?