KNOWLEDGE BASE

Error "Unable to connect using the DSN named "<ServerName>". Check that the DSN exists and is a valid connection" Refreshing Extract


Published: 06 Jan 2017
Last Modified Date: 17 Aug 2017

Issue

Scheduled extract refresh fails on Tableau Server with the following errors:
Unable to connect using the DSN named "<ServerName>". Check that the DSN exists and is a valid connection.
and
Tableau was unable to generate a query to perform this operation

Environment

  • Tableau Server 10.0.1 - 10.0.2
  • ODBC

Resolution

Upgrade to Tableau Server 10.0.3 or a newer version. For more information, see Upgrade Tableau Server.

Cause

This behavior is related to known issue 559326 which has been corrected in more recent versions.
Did this article resolve the issue?