KNOWLEDGE BASE

Error: "Unable to connect to the server" After Failing Multiple Time to Overwrite an Existing Workbook with "tabcmd publish"


Published: 16 Dec 2016
Last Modified Date: 24 May 2017

Issue

If tabcmd publish is used to publish and overwrite an existing workbook with a workbook that has an invalid data source connection information, the publication fails (as expected). However, if the original workbook is then (re)published via tabcmd, the second publish also fails with the same Bad Request error message similar to the following:

Unable to connect to the server.

Environment

Tableau Server 

Resolution

Option 1

Upgrade to Tableau Server: 10.2.2 or 10.1.8. For more information, see Upgrading Tableau Server.

Option 2

Use a unique name for the workbook after failing to attempt to publish the workbook that has valid data source connection. 

Cause

This behavior is related to a known issue (ID: 595513) that has been fixed in a recent version of Tableau Server.
Did this article resolve the issue?